parent
44e30a5cd6
commit
25cced970b
@ -1 +1 @@
|
|||||||
SHA512 (test-case-1.2.1.crate) = 40465eb74bd4fce98a8245c007d180fd552b06acc1f65f8f6d3376f23fcc631935260f2c3a2df0976213b5bb395736dddb8ee32b1e69d038469cf55aacf5cc6e
|
SHA512 (test-case-2.2.2.crate) = 505a417877f5e94e79ae14cce7ad003e1d10873d25fe71296110b6ad971a8f604cb5bea69109f0ddf641f7ca7ffb40203bb491b29d3d5e656c66f46dff470f41
|
||||||
|
@ -1,21 +1,56 @@
|
|||||||
--- test-case-1.2.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
--- test-case-2.2.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
+++ test-case-1.2.1/Cargo.toml 2021-11-02T20:50:35.711276+00:00
|
+++ test-case-2.2.2/Cargo.toml 2023-02-27T17:04:11.944205+00:00
|
||||||
@@ -15,7 +15,7 @@
|
@@ -18,7 +18,12 @@
|
||||||
version = "1.2.1"
|
"Wojciech Polak <frondeus@gmail.com>",
|
||||||
authors = ["Marcin Sas-Szymanski <marcin.sas-szymanski@anixe.pl>", "Wojciech Polak <frondeus@gmail.com>", "Łukasz Biel <lukasz.p.biel@gmail.com>"]
|
"Łukasz Biel <lukasz.p.biel@gmail.com>",
|
||||||
build = "build.rs"
|
]
|
||||||
-exclude = ["tests/snapshots/**/*"]
|
-exclude = ["tests/snapshots/**/*"]
|
||||||
+exclude = ["/ci", "/publish.sh", "README.tpl", "tests/snapshots/**/*"]
|
+exclude = [
|
||||||
|
+ "/ci",
|
||||||
|
+ "/publish.sh",
|
||||||
|
+ "README.tpl",
|
||||||
|
+ "tests/snapshots/**/*",
|
||||||
|
+]
|
||||||
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
|
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
|
||||||
documentation = "https://docs.rs/test-case"
|
documentation = "https://docs.rs/test-case"
|
||||||
readme = "README.md"
|
readme = "README.md"
|
||||||
@@ -29,9 +29,6 @@
|
@@ -40,10 +45,6 @@
|
||||||
|
path = "src/lib.rs"
|
||||||
doctest = false
|
doctest = false
|
||||||
proc-macro = true
|
|
||||||
|
|
||||||
-[[test]]
|
-[[test]]
|
||||||
-name = "acceptance"
|
-name = "acceptance"
|
||||||
-path = "tests/acceptance_tests.rs"
|
-path = "tests/acceptance_tests.rs"
|
||||||
[dependencies.cfg-if]
|
-
|
||||||
version = "1.0.0"
|
[dependencies.regex]
|
||||||
|
version = "1.5"
|
||||||
|
optional = true
|
||||||
|
@@ -53,7 +54,7 @@
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[dev-dependencies.indexmap]
|
||||||
|
-version = "=1.8.2"
|
||||||
|
+version = "1.8.2"
|
||||||
|
|
||||||
|
[dev-dependencies.insta]
|
||||||
|
version = "1.12"
|
||||||
|
@@ -62,16 +63,16 @@
|
||||||
|
version = "0.10"
|
||||||
|
|
||||||
|
[dev-dependencies.linked-hash-map]
|
||||||
|
-version = "=0.5.4"
|
||||||
|
+version = "0.5.4"
|
||||||
|
|
||||||
|
[dev-dependencies.once_cell]
|
||||||
|
-version = "=1.13.0"
|
||||||
|
+version = "1.13.0"
|
||||||
|
|
||||||
|
[dev-dependencies.regex]
|
||||||
|
version = "1.5"
|
||||||
|
|
||||||
|
[dev-dependencies.serde_yaml]
|
||||||
|
-version = "=0.8.25"
|
||||||
|
+version = "0.8.25"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
with-regex = [
|
||||||
|
Loading…
Reference in new issue