Update to version 2.2.2

epel9
Fabio Valentini 2 years ago
parent 44e30a5cd6
commit 25cced970b
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/test-case-1.2.0.crate /test-case-1.2.0.crate
/test-case-1.2.1.crate /test-case-1.2.1.crate
/test-case-2.2.2.crate

@ -1,29 +1,24 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate test-case %global crate test-case
Name: rust-%{crate} Name: rust-test-case
Version: 1.2.1 Version: 2.2.2
Release: %autorelease Release: %autorelease
Summary: Procedural macro attribute for generating parametrized test cases Summary: Procedural macro attribute for generating parametrized test cases
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/test-case URL: https://crates.io/crates/test-case
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Manually created patch for downstream crate metadata changes
# * drop acceptance tests that are not included in published crates # * drop acceptance tests that are not included in published crates
# * exclude some files that are only useful for upstream development # * exclude some files that are only useful for upstream development
Patch0: test-case-fix-metadata.diff # * relax version restrictions on dev-dependencies
Patch: test-case-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Provides #[test_case(...)] procedural macro attribute for generating Provides #[test_case(...)] procedural macro attribute for generating
@ -37,13 +32,14 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc README.md CHANGELOG.md %doc %{crate_instdir}/CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -51,23 +47,35 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hamcrest_assertions-devel %package -n %{name}+with-regex-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+hamcrest_assertions-devel %{_description} %description -n %{name}+with-regex-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "hamcrest_assertions" feature of "%{crate}" crate. use the "with-regex" feature of the "%{crate}" crate.
%files -n %{name}+hamcrest_assertions-devel %files -n %{name}+with-regex-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (test-case-1.2.1.crate) = 40465eb74bd4fce98a8245c007d180fd552b06acc1f65f8f6d3376f23fcc631935260f2c3a2df0976213b5bb395736dddb8ee32b1e69d038469cf55aacf5cc6e SHA512 (test-case-2.2.2.crate) = 505a417877f5e94e79ae14cce7ad003e1d10873d25fe71296110b6ad971a8f604cb5bea69109f0ddf641f7ca7ffb40203bb491b29d3d5e656c66f46dff470f41

@ -1,21 +1,56 @@
--- test-case-1.2.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- test-case-2.2.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ test-case-1.2.1/Cargo.toml 2021-11-02T20:50:35.711276+00:00 +++ test-case-2.2.2/Cargo.toml 2023-02-27T17:04:11.944205+00:00
@@ -15,7 +15,7 @@ @@ -18,7 +18,12 @@
version = "1.2.1" "Wojciech Polak <frondeus@gmail.com>",
authors = ["Marcin Sas-Szymanski <marcin.sas-szymanski@anixe.pl>", "Wojciech Polak <frondeus@gmail.com>", "Łukasz Biel <lukasz.p.biel@gmail.com>"] "Łukasz Biel <lukasz.p.biel@gmail.com>",
build = "build.rs" ]
-exclude = ["tests/snapshots/**/*"] -exclude = ["tests/snapshots/**/*"]
+exclude = ["/ci", "/publish.sh", "README.tpl", "tests/snapshots/**/*"] +exclude = [
+ "/ci",
+ "/publish.sh",
+ "README.tpl",
+ "tests/snapshots/**/*",
+]
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily" description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
documentation = "https://docs.rs/test-case" documentation = "https://docs.rs/test-case"
readme = "README.md" readme = "README.md"
@@ -29,9 +29,6 @@ @@ -40,10 +45,6 @@
path = "src/lib.rs"
doctest = false doctest = false
proc-macro = true
-[[test]] -[[test]]
-name = "acceptance" -name = "acceptance"
-path = "tests/acceptance_tests.rs" -path = "tests/acceptance_tests.rs"
[dependencies.cfg-if] -
version = "1.0.0" [dependencies.regex]
version = "1.5"
optional = true
@@ -53,7 +54,7 @@
default-features = false
[dev-dependencies.indexmap]
-version = "=1.8.2"
+version = "1.8.2"
[dev-dependencies.insta]
version = "1.12"
@@ -62,16 +63,16 @@
version = "0.10"
[dev-dependencies.linked-hash-map]
-version = "=0.5.4"
+version = "0.5.4"
[dev-dependencies.once_cell]
-version = "=1.13.0"
+version = "1.13.0"
[dev-dependencies.regex]
version = "1.5"
[dev-dependencies.serde_yaml]
-version = "=0.8.25"
+version = "0.8.25"
[features]
with-regex = [

Loading…
Cancel
Save