You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-test-case/test-case-fix-metadata.diff

57 lines
1.2 KiB

--- test-case-2.2.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ test-case-2.2.2/Cargo.toml 2023-02-27T17:04:11.944205+00:00
@@ -18,7 +18,12 @@
"Wojciech Polak <frondeus@gmail.com>",
"Łukasz Biel <lukasz.p.biel@gmail.com>",
]
-exclude = ["tests/snapshots/**/*"]
+exclude = [
+ "/ci",
+ "/publish.sh",
+ "README.tpl",
+ "tests/snapshots/**/*",
+]
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
documentation = "https://docs.rs/test-case"
readme = "README.md"
@@ -40,10 +45,6 @@
path = "src/lib.rs"
doctest = false
-[[test]]
-name = "acceptance"
-path = "tests/acceptance_tests.rs"
-
[dependencies.regex]
version = "1.5"
optional = true
@@ -53,7 +54,7 @@
default-features = false
[dev-dependencies.indexmap]
-version = "=1.8.2"
+version = "1.8.2"
[dev-dependencies.insta]
version = "1.12"
@@ -62,16 +63,16 @@
version = "0.10"
[dev-dependencies.linked-hash-map]
-version = "=0.5.4"
+version = "0.5.4"
[dev-dependencies.once_cell]
-version = "=1.13.0"
+version = "1.13.0"
[dev-dependencies.regex]
version = "1.5"
[dev-dependencies.serde_yaml]
-version = "=0.8.25"
+version = "0.8.25"
[features]
with-regex = [