parent
c064ebb380
commit
358318a41c
@ -1,25 +0,0 @@
|
|||||||
Description: Provide stubs for the two functions whose implementation is nonfree
|
|
||||||
Author: Sébastien Villemot <sebastien@debian.org>
|
|
||||||
Forwarded: not-needed
|
|
||||||
Last-Update: 2013-11-27
|
|
||||||
---
|
|
||||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/SRC/mc64ad.c
|
|
||||||
@@ -0,0 +1,16 @@
|
|
||||||
+#include <stdio.h>
|
|
||||||
+#include <stdlib.h>
|
|
||||||
+
|
|
||||||
+void mc64id_(int *a)
|
|
||||||
+{
|
|
||||||
+ fprintf(stderr, "SuperLU: MC64 functionality not available (it uses non-free code). Aborting.\n");
|
|
||||||
+ abort();
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+void mc64ad_(int *a, int *b, int *c, int d[], int e[], double f[],
|
|
||||||
+ int *g, int h[], int *i, int j[], int *k, double l[],
|
|
||||||
+ int m[], int n[])
|
|
||||||
+{
|
|
||||||
+ fprintf(stderr, "SuperLU: MC64 functionality not available (it uses non-free code). Aborting.\n");
|
|
||||||
+ abort();
|
|
||||||
+}
|
|
@ -1,14 +0,0 @@
|
|||||||
--- /tmp/SuperLU_5.2.0/SRC/CMakeLists.txt 2016-04-09 03:53:17.000000000 +0200
|
|
||||||
+++ SuperLU_5.2.0/SRC/CMakeLists.txt 2018-04-13 11:42:28.481583088 +0200
|
|
||||||
@@ -233,9 +233,9 @@
|
|
||||||
VERSION ${PROJECT_VERSION} SOVERSION ${VERSION_MAJOR}
|
|
||||||
)
|
|
||||||
install(TARGETS superlu
|
|
||||||
- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
|
|
||||||
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
||||||
)
|
|
||||||
|
|
||||||
install(FILES ${headers}
|
|
||||||
- DESTINATION ${CMAKE_INSTALL_PREFIX}/include
|
|
||||||
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
|
|
||||||
)
|
|
Loading…
Reference in new issue