* Tue Mar 10 2009 Dominik Mierzejewski <rpm@greysector.net> 0.0.0-0.24.20090310git5b65cc

- 20090310 snapshot
- build with static gpac
el8
Dominik Mierzejewski 16 years ago
parent 81733b380d
commit 33eb3c8f8c

2
.gitignore vendored

@ -1 +1 @@
x264-20090119.tar.bz2 x264-20090310.tar.bz2

@ -1 +1 @@
0e4de4b2c2b551a107ee136c22d4e2f3 x264-20090119.tar.bz2 9bfa0ecd434dc1daebdd4c1bacbda188 x264-20090310.tar.bz2

@ -1,7 +1,7 @@
diff -up x264-20090119/configure.r x264-20090119/configure diff -up x264-20090310/configure.r x264-20090310/configure
--- x264-20090119/configure.r 2009-02-10 20:05:17.000000000 +0100 --- x264-20090310/configure.r 2009-03-10 23:48:14.000000000 +0100
+++ x264-20090119/configure 2009-02-10 20:06:33.000000000 +0100 +++ x264-20090310/configure 2009-03-11 01:40:31.000000000 +0100
@@ -41,7 +41,7 @@ as_check() { @@ -42,7 +42,7 @@ as_check() {
return $TMP return $TMP
} }
@ -10,27 +10,15 @@ diff -up x264-20090119/configure.r x264-20090119/configure
prefix='/usr/local' prefix='/usr/local'
exec_prefix='${prefix}' exec_prefix='${prefix}'
@@ -239,6 +239,7 @@ case $host_cpu in @@ -236,6 +236,7 @@ case $host_cpu in
i*86)
ARCH="X86" ARCH="X86"
ASFLAGS="-O2" AS="yasm"
ASFLAGS="$ASFLAGS -O2"
+ LDFLAGS="$LDFLAGS -m32" + LDFLAGS="$LDFLAGS -m32"
if [ "$SYS" = MACOSX ]; then if [ "$SYS" = MACOSX ]; then
ASFLAGS="$ASFLAGS -f macho -DPREFIX" ASFLAGS="$ASFLAGS -f macho -DPREFIX"
elif [ "$SYS" = MINGW ]; then elif [ "$SYS" = MINGW ]; then
@@ -352,7 +353,11 @@ if test "$pthread" = "yes" ; then @@ -466,8 +471,6 @@ if [ "$shared" = "yes" ]; then
LDFLAGS="$LDFLAGS $libpthread"
fi
+if [ "$shared" = "yes" ]; then
+MP4_LDFLAGS="-lgpac"
+else
MP4_LDFLAGS="-lgpac_static"
+fi
if [ $SYS = MINGW ]; then
MP4_LDFLAGS="$MP4_LDFLAGS -lwinmm"
fi
@@ -452,8 +457,6 @@ if [ "$shared" = "yes" ]; then
echo 'default: $(SONAME)' >> config.mak echo 'default: $(SONAME)' >> config.mak
fi fi
@ -39,12 +27,12 @@ diff -up x264-20090119/configure.r x264-20090119/configure
pclibs="-L$libdir -lx264 $libpthread" pclibs="-L$libdir -lx264 $libpthread"
cat > x264.pc << EOF cat > x264.pc << EOF
diff -up x264-20090119/Makefile.r x264-20090119/Makefile diff -up x264-20090310/Makefile.r x264-20090310/Makefile
--- x264-20090119/Makefile.r 2009-02-10 20:05:17.000000000 +0100 --- x264-20090310/Makefile.r 2009-03-10 23:48:14.000000000 +0100
+++ x264-20090119/Makefile 2009-02-10 20:06:02.000000000 +0100 +++ x264-20090310/Makefile 2009-03-11 01:39:35.000000000 +0100
@@ -77,14 +77,25 @@ libx264.a: .depend $(OBJS) $(OBJASM) @@ -77,14 +77,25 @@ libx264.a: .depend $(OBJS) $(OBJASM)
ar rc libx264.a $(OBJS) $(OBJASM) $(AR) rc libx264.a $(OBJS) $(OBJASM)
ranlib libx264.a $(RANLIB) libx264.a
+libx264.so: $(SONAME) +libx264.so: $(SONAME)
+ ln -sf $(SONAME) libx264.$(SOSUFFIX) + ln -sf $(SONAME) libx264.$(SOSUFFIX)
@ -68,17 +56,17 @@ diff -up x264-20090119/Makefile.r x264-20090119/Makefile
%.o: %.asm %.o: %.asm
$(AS) $(ASFLAGS) -o $@ $< $(AS) $(ASFLAGS) -o $@ $<
@@ -148,10 +159,12 @@ install: x264$(EXE) $(SONAME) @@ -147,10 +158,12 @@ install: x264$(EXE) $(SONAME)
install -d $(DESTDIR)$(bindir) $(DESTDIR)$(includedir) install -d $(DESTDIR)$(bindir) $(DESTDIR)$(includedir)
install -d $(DESTDIR)$(libdir) $(DESTDIR)$(libdir)/pkgconfig install -d $(DESTDIR)$(libdir) $(DESTDIR)$(libdir)/pkgconfig
install -m 644 x264.h $(DESTDIR)$(includedir) install -m 644 x264.h $(DESTDIR)$(includedir)
+ifeq ($(SONAME),) +ifeq ($(SONAME),)
install -m 644 libx264.a $(DESTDIR)$(libdir) install -m 644 libx264.a $(DESTDIR)$(libdir)
+ ranlib $(DESTDIR)$(libdir)/libx264.a + $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
+endif +endif
install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
install x264$(EXE) $(DESTDIR)$(bindir) install x264$(EXE) $(DESTDIR)$(bindir)
- ranlib $(DESTDIR)$(libdir)/libx264.a - $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
ifeq ($(SYS),MINGW) ifeq ($(SYS),MINGW)
$(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir)) $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
else else

@ -1,10 +1,10 @@
%define snapshot 20090119 %define snapshot 20090310
%define git 451ba8d %define git 5b65cc
Summary: H264/AVC video streams encoder Summary: H264/AVC video streams encoder
Name: x264 Name: x264
Version: 0.0.0 Version: 0.0.0
Release: 0.23.%{snapshot}git%{git}%{?dist} Release: 0.24.%{snapshot}git%{git}%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://developers.videolan.org/x264.html URL: http://developers.videolan.org/x264.html
@ -12,7 +12,7 @@ Source0: http://rpm.greysector.net/livna/%{name}-%{snapshot}.tar.bz2
Source1: x264-snapshot.sh Source1: x264-snapshot.sh
Patch0: %{name}-rpm.patch Patch0: %{name}-rpm.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
%{?_with_gpac:BuildRequires: gpac-devel} %{!?_without_gpac:BuildRequires: gpac-devel-static}
%{?_with_visualize:BuildRequires: libX11-devel} %{?_with_visualize:BuildRequires: libX11-devel}
%ifarch x86_64 %{ix86} %ifarch x86_64 %{ix86}
BuildRequires: yasm BuildRequires: yasm
@ -54,7 +54,7 @@ This package contains the development files.
--bindir=%{_bindir} \\\ --bindir=%{_bindir} \\\
--includedir=%{_includedir} \\\ --includedir=%{_includedir} \\\
--extra-cflags="$RPM_OPT_FLAGS" \\\ --extra-cflags="$RPM_OPT_FLAGS" \\\
%{?_with_gpac:--enable-mp4-output} \\\ %{!?_without_gpac:--enable-mp4-output} \\\
%{?_with_visualize:--enable-visualize} \\\ %{?_with_visualize:--enable-visualize} \\\
--enable-pthread \\\ --enable-pthread \\\
--enable-debug \\\ --enable-debug \\\
@ -132,6 +132,10 @@ popd
%endif %endif
%changelog %changelog
* Tue Mar 10 2009 Dominik Mierzejewski <rpm@greysector.net> 0.0.0-0.24.20090310git5b65cc
- 20090310 snapshot
- build with static gpac
* Tue Feb 10 2009 Dominik Mierzejewski <rpm@greysector.net> 0.0.0-0.23.20090119git451ba8d * Tue Feb 10 2009 Dominik Mierzejewski <rpm@greysector.net> 0.0.0-0.23.20090119git451ba8d
- 20090119 snapshot - 20090119 snapshot
- fix BRs for build-time options - fix BRs for build-time options

Loading…
Cancel
Save