You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
x264/x264-rpm.patch

73 lines
2.1 KiB

diff -up x264-20090310/configure.r x264-20090310/configure
--- x264-20090310/configure.r 2009-03-10 23:48:14.000000000 +0100
+++ x264-20090310/configure 2009-03-11 01:40:31.000000000 +0100
@@ -42,7 +42,7 @@ as_check() {
return $TMP
}
-rm -f config.h config.mak x264.pc conftest*
+rm -f config.mak x264.pc conftest*
prefix='/usr/local'
exec_prefix='${prefix}'
@@ -236,6 +236,7 @@ case $host_cpu in
ARCH="X86"
AS="yasm"
ASFLAGS="$ASFLAGS -O2"
+ LDFLAGS="$LDFLAGS -m32"
if [ "$SYS" = MACOSX ]; then
ASFLAGS="$ASFLAGS -f macho -DPREFIX"
elif [ "$SYS" = MINGW ]; then
@@ -466,8 +471,6 @@ if [ "$shared" = "yes" ]; then
echo 'default: $(SONAME)' >> config.mak
fi
-./version.sh
-
pclibs="-L$libdir -lx264 $libpthread"
cat > x264.pc << EOF
diff -up x264-20090310/Makefile.r x264-20090310/Makefile
--- x264-20090310/Makefile.r 2009-03-10 23:48:14.000000000 +0100
+++ x264-20090310/Makefile 2009-03-11 01:39:35.000000000 +0100
@@ -77,14 +77,25 @@ libx264.a: .depend $(OBJS) $(OBJASM)
$(AR) rc libx264.a $(OBJS) $(OBJASM)
$(RANLIB) libx264.a
+libx264.so: $(SONAME)
+ ln -sf $(SONAME) libx264.$(SOSUFFIX)
+
$(SONAME): .depend $(OBJS) $(OBJASM)
$(CC) -shared -o $@ $(OBJS) $(OBJASM) $(SOFLAGS) $(LDFLAGS)
+ifeq ($(SONAME),)
x264$(EXE): $(OBJCLI) libx264.a
$(CC) -o $@ $+ $(LDFLAGS)
checkasm: tools/checkasm.o libx264.a
$(CC) -o $@ $+ $(LDFLAGS)
+else
+x264$(EXE): $(OBJCLI) libx264.so
+ $(CC) -o $@ $+ $(LDFLAGS) -lx264 -L.
+
+checkasm: tools/checkasm.o $(SONAME)
+ $(CC) -o $@ $+ $(LDFLAGS) -lx264 -L.
+endif
%.o: %.asm
$(AS) $(ASFLAGS) -o $@ $<
@@ -147,10 +158,12 @@ install: x264$(EXE) $(SONAME)
install -d $(DESTDIR)$(bindir) $(DESTDIR)$(includedir)
install -d $(DESTDIR)$(libdir) $(DESTDIR)$(libdir)/pkgconfig
install -m 644 x264.h $(DESTDIR)$(includedir)
+ifeq ($(SONAME),)
install -m 644 libx264.a $(DESTDIR)$(libdir)
+ $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
+endif
install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
install x264$(EXE) $(DESTDIR)$(bindir)
- $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
ifeq ($(SYS),MINGW)
$(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
else