Update to 1.5.3

epel9
Leigh Scott 4 years ago
parent 7704eed404
commit 8475e0505f

@ -1,18 +1,6 @@
From 79d6313628216f9c5d6e758d8d113c97df152ad9 Mon Sep 17 00:00:00 2001
From: Leigh Scott <leigh123linux@gmail.com>
Date: Wed, 4 Mar 2020 21:49:48 +0000
Subject: [PATCH 2/4] Unbundle pugixml
---
libvmaf/src/meson.build | 7 +++++--
libvmaf/src/vmaf.cpp | 2 +-
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/libvmaf/src/meson.build b/libvmaf/src/meson.build
index 74047d2..9f723d8 100644
--- a/libvmaf/src/meson.build
+++ b/libvmaf/src/meson.build
@@ -31,6 +31,7 @@ ptools_sources = [
@@ -187,6 +187,7 @@ ptools_sources = [
]
thread_lib = dependency('threads')
@ -20,7 +8,7 @@ index 74047d2..9f723d8 100644
math_lib = cc.find_library('m', required : false)
libptools = shared_library(
@@ -115,7 +116,6 @@ libvmaf_feature_static_lib = static_library(
@@ -241,7 +242,6 @@ libvmaf_feature_static_lib = static_libr
)
vmaf_sources = [
@ -28,20 +16,15 @@ index 74047d2..9f723d8 100644
src_dir + 'mem.c',
src_dir + 'combo.c',
src_dir + 'cpu_info.c',
@@ -131,7 +131,10 @@ libvmaf = both_libraries(
@@ -257,7 +257,7 @@ libvmaf = both_libraries(
include_directories : vmaf_include,
c_args : vmaf_cflags_common,
cpp_args : vmaf_cflags_common,
- dependencies : thread_lib,
+ dependencies : [
+ thread_lib,
+ pugixml_lib,
+ ],
- dependencies : [thread_lib, stdatomic_dependency],
+ dependencies : [thread_lib, pugixml_lib, stdatomic_dependency],
objects : [
convolution_and_psnr_avx_static_lib.extract_all_objects(),
platform_specific_cpu_objects,
libptools.extract_all_objects(),
diff --git a/libvmaf/src/vmaf.cpp b/libvmaf/src/vmaf.cpp
index 64bcf5f..c9cab57 100644
--- a/libvmaf/src/vmaf.cpp
+++ b/libvmaf/src/vmaf.cpp
@@ -28,7 +28,7 @@
@ -53,6 +36,4 @@ index 64bcf5f..c9cab57 100644
#include "timer.h"
#include "jsonprint.h"
#include "debug.h"
--
2.24.1

@ -1,24 +0,0 @@
From 564d4c50e35bbb7428cab8ae58d31313fdfe065b Mon Sep 17 00:00:00 2001
From: Leigh Scott <leigh123linux@gmail.com>
Date: Wed, 4 Mar 2020 21:52:08 +0000
Subject: [PATCH 3/4] Fix soname
---
libvmaf/src/meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/libvmaf/src/meson.build b/libvmaf/src/meson.build
index 9f723d8..1295b71 100644
--- a/libvmaf/src/meson.build
+++ b/libvmaf/src/meson.build
@@ -129,6 +129,7 @@ libvmaf = both_libraries(
'vmaf',
vmaf_sources,
include_directories : vmaf_include,
+ soversion: 0,
c_args : vmaf_cflags_common,
cpp_args : vmaf_cflags_common,
dependencies : [
--
2.24.1

@ -1,39 +0,0 @@
From f6acf39e17ce3d1e607be243c263dffbac9cb862 Mon Sep 17 00:00:00 2001
From: Leigh Scott <leigh123linux@gmail.com>
Date: Wed, 4 Mar 2020 22:06:51 +0000
Subject: [PATCH 4/4] Avoid x86cpudetection code when not relevant
---
libvmaf/src/feature/common/cpu.c | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/libvmaf/src/feature/common/cpu.c b/libvmaf/src/feature/common/cpu.c
index ff96ddc..efcb8ec 100644
--- a/libvmaf/src/feature/common/cpu.c
+++ b/libvmaf/src/feature/common/cpu.c
@@ -16,9 +16,10 @@
*
*/
-#include "cpudetect.h"
#include "cpu.h"
+#if defined(__i386__) || defined(__x86_64)
+#include "cpudetect.h"
enum vmaf_cpu cpu_autodetect()
{
@@ -31,3 +32,10 @@ enum vmaf_cpu cpu_autodetect()
else
return VMAF_CPU_NONE;
}
+
+#else
+enum vmaf_cpu cpu_autodetect()
+{
+ return VMAF_CPU_NONE;
+}
+#endif
--
2.24.1

@ -12,7 +12,7 @@ index 2550f29..117bad0 100644
--- a/libvmaf/tools/meson.build
+++ b/libvmaf/tools/meson.build
@@ -8,7 +8,7 @@ vmafossexec = executable(
include_directories : libvmaf_inc,
dependencies: [stdatomic_dependency],
c_args : vmaf_cflags_common,
cpp_args : vmaf_cflags_common,
- link_with : libvmaf.get_static_lib(),

@ -1,30 +0,0 @@
From ea25229433f7f8ff087c63db9509156c01a8e291 Mon Sep 17 00:00:00 2001
From: Jan Beich <jbeich@FreeBSD.org>
Date: Sat, 29 Feb 2020 15:12:09 +0000
Subject: [PATCH] libvmaf: mark ABI as C after 82a86e040371
---
libvmaf/include/libvmaf/libvmaf.h | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/libvmaf/include/libvmaf/libvmaf.h b/libvmaf/include/libvmaf/libvmaf.h
index ef32e069..2fbb3599 100644
--- a/libvmaf/include/libvmaf/libvmaf.h
+++ b/libvmaf/include/libvmaf/libvmaf.h
@@ -19,8 +19,16 @@
#ifndef LIBVMAF_H_
#define LIBVMAF_H_
+#ifdef __cplusplus
+extern "C" {
+#endif
+
int compute_vmaf(double* vmaf_score, char* fmt, int width, int height, int (*read_frame)(float *ref_data, float *main_data, float *temp_data, int stride_byte, void *user_data),
void *user_data, char *model_path, char *log_path, char *log_fmt, int disable_clip, int disable_avx, int enable_transform, int phone_model, int do_psnr,
int do_ssim, int do_ms_ssim, char *pool_method, int n_thread, int n_subsample, int enable_conf_interval);
+#ifdef __cplusplus
+}
+#endif
+
#endif /* _LIBVMAF_H */

@ -1 +1 @@
SHA512 (vmaf-1.5.1.tar.gz) = f587c70fd830a491e9c75f65bc4f4bff137218c504aab7d3d4f2eba1affaac8a32eb6049ec00ad8db6a4f26079c555da3d5803f14f9dd01c199cc89df2e4a975
SHA512 (vmaf-1.5.3.tar.gz) = 8d8420c72a6575669e88506e47a381c39b66b087b60aef359fb073cd2a54a8fdf48d2664e03e60612afc437b404bfab9d92b9f2441304a612e8d07a2d6947ba5

@ -1,6 +1,6 @@
Name: vmaf
Version: 1.5.1
Release: 5%{?dist}
Version: 1.5.3
Release: 1%{?dist}
Summary: Video Multi-Method Assessment Fusion
License: BSD-2-Clause-Patent
@ -8,10 +8,7 @@ URL: https://github.com/netflix/vmaf
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: 0001-Use-better-FLAGS-for-ptools.patch
Patch1: 0002-Unbundle-pugixml.patch
Patch3: 0003-Fix-soname.patch
Patch4: 0004-Avoid-x86cpudetection-code-when-not-relevant.patch
Patch5: 0005-Use-shared-for-vmafossexec.patch
Patch6: %{url}/commit/ea25229433f7f8ff087c63db9509156c01a8e291.patch#/mark_abi_c.patch
Patch2: 0005-Use-shared-for-vmafossexec.patch
# This project relies on AVX
ExclusiveArch: x86_64
@ -64,7 +61,6 @@ developing applications that use %{name}.
# Unbundle
rm -rf libvmaf/src/third_party/pugixml
rm -rf third_party/libsvm
sed -i -e 's@1.3.16@%{version}@g' libvmaf/meson.build
%build
pushd libvmaf
@ -77,10 +73,10 @@ pushd libvmaf
%meson_install
popd
mv %{buildroot}%{_libdir}/libvmaf.so.0 \
%{buildroot}%{_libdir}/libvmaf.so.0.0.0
ln -s libvmaf.so.0.0.0 \
%{buildroot}%{_libdir}/libvmaf.so.0
#mv %{buildroot}%{_libdir}/libvmaf.so.0 \
# %{buildroot}%{_libdir}/libvmaf.so.0.0.0
#ln -s libvmaf.so.0.0.0 \
# %{buildroot}%{_libdir}/libvmaf.so.0
rm -f %{buildroot}%{_libdir}/libvmaf.a
#RPM Macros support
@ -114,6 +110,9 @@ touch -r LICENSE %{buildroot}%{rpmmacrodir}/macros.%{name}
%changelog
* Thu Dec 31 2020 Leigh Scott <leigh123linux@gmail.com> - 1.5.3-1
- Update to 1.5.3
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

Loading…
Cancel
Save