You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
40 lines
1.1 KiB
40 lines
1.1 KiB
--- a/libvmaf/src/meson.build
|
|
+++ b/libvmaf/src/meson.build
|
|
@@ -187,6 +187,7 @@ ptools_sources = [
|
|
]
|
|
|
|
thread_lib = dependency('threads')
|
|
+pugixml_lib = dependency('pugixml')
|
|
math_lib = cc.find_library('m', required : false)
|
|
|
|
libptools = shared_library(
|
|
@@ -241,7 +242,6 @@ libvmaf_feature_static_lib = static_libr
|
|
)
|
|
|
|
vmaf_sources = [
|
|
- third_party_dir + 'pugixml/pugixml.cpp',
|
|
src_dir + 'mem.c',
|
|
src_dir + 'combo.c',
|
|
src_dir + 'cpu_info.c',
|
|
@@ -257,7 +257,7 @@ libvmaf = both_libraries(
|
|
include_directories : vmaf_include,
|
|
c_args : vmaf_cflags_common,
|
|
cpp_args : vmaf_cflags_common,
|
|
- dependencies : [thread_lib, stdatomic_dependency],
|
|
+ dependencies : [thread_lib, pugixml_lib, stdatomic_dependency],
|
|
objects : [
|
|
platform_specific_cpu_objects,
|
|
libptools.extract_all_objects(),
|
|
--- a/libvmaf/src/vmaf.cpp
|
|
+++ b/libvmaf/src/vmaf.cpp
|
|
@@ -28,7 +28,7 @@
|
|
|
|
#include "vmaf.h"
|
|
#include "combo.h"
|
|
-#include "third_party/pugixml/pugixml.hpp"
|
|
+#include <pugixml.hpp>
|
|
#include "timer.h"
|
|
#include "jsonprint.h"
|
|
#include "debug.h"
|
|
|