Initial import (#2254538)

epel9 imports/e9/rust-z-base-32-0.1.3-1.el9
Fabio Valentini 1 year ago
parent 5b56c766d0
commit ad37fe40fe
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/z-base-32-0.1.3.crate

@ -1,3 +0,0 @@
# rust-z-base-32
The rust-z-base-32 package

@ -0,0 +1,72 @@
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate z-base-32
Name: rust-z-base-32
Version: 0.1.3
Release: %autorelease
Summary: Z-base-32: human-oriented base-32 encoding
License: MIT
URL: https://crates.io/crates/z-base-32
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop support for building as a Python module
Patch: z-base-32-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Z-base-32: human-oriented base-32 encoding.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (z-base-32-0.1.3.crate) = ae3a87440622ce39dc157be7eb5765c22eab758a4ad475c229d78fd34ecd3d4d7f0b24557bcda729b4215217dc93113453cfbe8d6c32f1dbc8e67ee3ece66c5b

@ -0,0 +1,28 @@
--- z-base-32-0.1.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ z-base-32-0.1.3/Cargo.toml 2023-12-14T12:00:29.111751+00:00
@@ -26,21 +26,13 @@
categories = ["encoding"]
license = "MIT"
repository = "https://github.com/matusf/z-base-32"
+exclude = [
+ "/pyproject.toml",
+ "/test.py",
+]
[lib]
name = "zbase32"
-crate-type = [
- "cdylib",
- "rlib",
-]
-
-[dependencies.pyo3]
-version = "0.20.0"
-features = ["extension-module"]
-optional = true
[dev-dependencies.quickcheck]
version = "1"
-
-[features]
-python = ["pyo3"]
Loading…
Cancel
Save