Update to version 1.11.0; Fixes RHBZ#2319073

epel10 imports/epel10/rust-uuid-1.11.0-1.el10
Fabio Valentini 4 months ago
parent 4722cfcfff
commit 8911af484d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -27,3 +27,4 @@
/uuid-1.9.0.crate /uuid-1.9.0.crate
/uuid-1.9.1.crate /uuid-1.9.1.crate
/uuid-1.10.0.crate /uuid-1.10.0.crate
/uuid-1.11.0.crate

@ -5,7 +5,7 @@
%global crate uuid %global crate uuid
Name: rust-uuid Name: rust-uuid
Version: 1.10.0 Version: 1.11.0
Release: %autorelease Release: %autorelease
Summary: Library to generate and parse UUIDs Summary: Library to generate and parse UUIDs
@ -16,6 +16,7 @@ Source: %{crates_source}
Patch: uuid-fix-metadata-auto.diff Patch: uuid-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop unused optional dependency for borsh support # * drop unused optional dependency for borsh support
# * drop unused optional dependency for zerocopy support
# * drop WASM-specific features and dependencies # * drop WASM-specific features and dependencies
# * drop internal-only features # * drop internal-only features
Patch: uuid-fix-metadata.diff Patch: uuid-fix-metadata.diff
@ -258,18 +259,6 @@ use the "v8" feature of the "%{crate}" crate.
%files -n %{name}+v8-devel %files -n %{name}+v8-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zerocopy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zerocopy-devel %{_description}
This package contains library source intended for building other packages which
use the "zerocopy" feature of the "%{crate}" crate.
%files -n %{name}+zerocopy-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep

@ -1,6 +1,7 @@
[package] [package]
cargo-toml-patch-comments = [ cargo-toml-patch-comments = [
"drop unused optional dependency for borsh support", "drop unused optional dependency for borsh support",
"drop unused optional dependency for zerocopy support",
"drop WASM-specific features and dependencies", "drop WASM-specific features and dependencies",
"drop internal-only features", "drop internal-only features",
] ]

@ -1 +1 @@
SHA512 (uuid-1.10.0.crate) = e17db9433d919b51468acaebd240a2cb218d07f099fade49118ca9313f8cdf6aa3103e7aa24440be65a4f25a25f8f511e36dba08cbef27747f9e43b849cd612b SHA512 (uuid-1.11.0.crate) = 0cd1b95fc2247bf4e627de6abb41e332ebaf39e5720640e52b9f235f7a0e2d451e7a486efdabb616ce00e47832d21919611683d0e6a71c86a86f290940cfda32

@ -1,6 +1,6 @@
--- uuid-1.10.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.10.0/Cargo.toml 2024-07-31T15:34:42.021322+00:00 +++ uuid-1.11.0/Cargo.toml 2024-10-20T14:19:57.658776+00:00
@@ -169,7 +169,6 @@ @@ -178,7 +178,6 @@
"dep:rand", "dep:rand",
] ]
js = [ js = [
@ -8,25 +8,25 @@
"getrandom?/js", "getrandom?/js",
] ]
macro-diagnostics = ["dep:uuid-macro-internal"] macro-diagnostics = ["dep:uuid-macro-internal"]
@@ -185,16 +184,6 @@ @@ -194,16 +193,6 @@
v7 = ["rng"] v7 = ["rng"]
v8 = [] v8 = []
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\"))".dependencies.wasm-bindgen] -[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dependencies.wasm-bindgen]
-version = "0.2" -version = "0.2"
-optional = true -optional = true
- -
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test] -[target.'cfg(all(target_arch = "wasm32", target_vendor = "unknown", target_os = "unknown"))'.dev-dependencies.wasm-bindgen-test]
-version = "0.3" -version = "0.3"
- -
-[target."cfg(target = \"wasm32-unknown-unknown\")".dev-dependencies.wasm-bindgen] -[target.'cfg(target = "wasm32-unknown-unknown")'.dev-dependencies.wasm-bindgen]
-version = "0.2" -version = "0.2"
- -
[badges.is-it-maintained-issue-resolution] [badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid" repository = "uuid-rs/uuid"
@@ -207,3 +196,4 @@ @@ -217,3 +206,4 @@
[lints.rust.unexpected_cfgs]
level = "allow" level = "allow"
priority = 0 priority = 0
check-cfg = ["cfg(uuid_unstable)"]
+ +

@ -1,6 +1,6 @@
--- uuid-1.10.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.10.0/Cargo.toml 2024-07-31T15:36:07.779549+00:00 +++ uuid-1.11.0/Cargo.toml 2024-10-20T14:20:19.529890+00:00
@@ -48,7 +48,6 @@ @@ -53,7 +53,6 @@
"serde", "serde",
"arbitrary", "arbitrary",
"slog", "slog",
@ -8,7 +8,7 @@
"v1", "v1",
"v3", "v3",
"v4", "v4",
@@ -88,16 +87,6 @@ @@ -97,16 +96,6 @@
optional = true optional = true
default-features = false default-features = false
@ -25,18 +25,23 @@
[dependencies.bytemuck] [dependencies.bytemuck]
version = "1.14.0" version = "1.14.0"
features = ["derive"] features = ["derive"]
@@ -130,10 +119,6 @@ @@ -139,15 +128,6 @@
version = "2" version = "2"
optional = true optional = true
-[dependencies.uuid-macro-internal] -[dependencies.uuid-macro-internal]
-version = "1.10.0" -version = "1.11.0"
-optional = true -optional = true
- -
[dependencies.zerocopy] -[dependencies.zerocopy]
version = "0.7" -version = "0.8"
features = ["derive"] -features = ["derive"]
@@ -159,19 +144,11 @@ -optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -168,19 +148,11 @@
[features] [features]
atomic = ["dep:atomic"] atomic = ["dep:atomic"]

Loading…
Cancel
Save