You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-uuid/uuid-fix-metadata.diff

64 lines
1.1 KiB

--- uuid-1.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.11.0/Cargo.toml 2024-10-20T14:20:19.529890+00:00
@@ -53,7 +53,6 @@
"serde",
"arbitrary",
"slog",
- "borsh",
"v1",
"v3",
"v4",
@@ -97,16 +96,6 @@
optional = true
default-features = false
-[dependencies.borsh]
-version = "1"
-optional = true
-default-features = false
-
-[dependencies.borsh-derive]
-version = "1"
-optional = true
-default-features = false
-
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -139,15 +128,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.11.0"
-optional = true
-
-[dependencies.zerocopy]
-version = "0.8"
-features = ["derive"]
-optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -168,19 +148,11 @@
[features]
atomic = ["dep:atomic"]
-borsh = [
- "dep:borsh",
- "dep:borsh-derive",
-]
default = ["std"]
fast-rng = [
"rng",
"dep:rand",
]
-js = [
- "getrandom?/js",
-]
-macro-diagnostics = ["dep:uuid-macro-internal"]
md5 = ["dep:md-5"]
rng = ["dep:getrandom"]
sha1 = ["dep:sha1_smol"]