Update to version 1.9.0; Fixes RHBZ#2293884

epel10
Fabio Valentini 8 months ago
parent d8a229b864
commit 7006027c6d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -24,3 +24,4 @@
/uuid-1.6.1.crate
/uuid-1.7.0.crate
/uuid-1.8.0.crate
/uuid-1.9.0.crate

@ -5,7 +5,7 @@
%global crate uuid
Name: rust-uuid
Version: 1.8.0
Version: 1.9.0
Release: %autorelease
Summary: Library to generate and parse UUIDs
@ -258,6 +258,18 @@ use the "v8" feature of the "%{crate}" crate.
%files -n %{name}+v8-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zerocopy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zerocopy-devel %{_description}
This package contains library source intended for building other packages which
use the "zerocopy" feature of the "%{crate}" crate.
%files -n %{name}+zerocopy-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

@ -0,0 +1,7 @@
[package]
cargo-toml-patch-comments = [
"drop unused optional dependency for borsh support",
"drop WASM-specific features and dependencies",
"drop internal-only features",
]

@ -1 +1 @@
SHA512 (uuid-1.8.0.crate) = fe254f0bf6b863538ce568405569a4c755b33bce561148661b10985bf4485fa7ee7a6ec650d93656552b3cdead46b2074ebfd45b040edef19cd1648300f68ed5
SHA512 (uuid-1.9.0.crate) = d04b525d6f2452c2aeaa15de7b754a3ca9867ffb27f1d94df22ce5ba024996c890e06f4c69a9104399b364c7292570359f922ad7e6980f477b6b336c8ad5557a

@ -1,5 +1,5 @@
--- uuid-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.8.0/Cargo.toml 2024-03-19T19:40:55.258557+00:00
--- uuid-1.9.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.9.0/Cargo.toml 2024-06-24T16:35:28.093978+00:00
@@ -169,7 +169,6 @@
"dep:rand",
]
@ -25,8 +25,8 @@
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"
@@ -206,3 +195,4 @@
[badges.maintenance]
status = "actively-developed"
@@ -210,3 +199,4 @@
[lints.rust.unexpected_cfgs]
level = "allow"
priority = 0
+

@ -1,6 +1,6 @@
--- uuid-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.8.0/Cargo.toml 2024-03-19T19:42:03.438839+00:00
@@ -89,16 +89,6 @@
--- uuid-1.9.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.9.0/Cargo.toml 2024-06-24T16:36:48.035279+00:00
@@ -88,16 +88,6 @@
optional = true
default-features = false
@ -17,22 +17,18 @@
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -131,14 +121,6 @@
@@ -130,10 +120,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.8.0"
-version = "1.9.0"
-optional = true
-
-[dependencies.zerocopy]
-version = "0.6"
-optional = true
-
[dev-dependencies.bincode]
version = "1.0"
@@ -159,19 +141,11 @@
[dependencies.zerocopy]
version = "0.7"
features = ["derive"]
@@ -159,19 +145,11 @@
[features]
atomic = ["dep:atomic"]

Loading…
Cancel
Save