Update to version 1.8.0; Fixes RHBZ#2270213

epel10
Fabio Valentini 11 months ago
parent a0703b58d5
commit d8a229b864
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -23,3 +23,4 @@
/uuid-1.5.0.crate
/uuid-1.6.1.crate
/uuid-1.7.0.crate
/uuid-1.8.0.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate uuid
Name: rust-uuid
Version: 1.7.0
Version: 1.8.0
Release: %autorelease
Summary: Library to generate and parse UUIDs

@ -1 +1 @@
SHA512 (uuid-1.7.0.crate) = 2ea704d082b725d98717d772e1af84fe743929ee32658ebeb111c6fa2395ff5f44558b7e375087617f91c6f7bc242f2db96e80a631071722de6fe15af845e856
SHA512 (uuid-1.8.0.crate) = fe254f0bf6b863538ce568405569a4c755b33bce561148661b10985bf4485fa7ee7a6ec650d93656552b3cdead46b2074ebfd45b040edef19cd1648300f68ed5

@ -1,9 +1,21 @@
--- uuid-1.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.7.0/Cargo.toml 2024-01-30T12:39:54.882093+00:00
@@ -192,12 +192,6 @@
--- uuid-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.8.0/Cargo.toml 2024-03-19T19:40:55.258557+00:00
@@ -169,7 +169,6 @@
"dep:rand",
]
js = [
- "dep:wasm-bindgen",
"getrandom?/js",
]
macro-diagnostics = ["dep:uuid-macro-internal"]
@@ -188,16 +187,6 @@
]
v8 = []
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\"))".dependencies.wasm-bindgen]
-version = "0.2"
-optional = true
-
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
@ -13,7 +25,7 @@
[badges.is-it-maintained-issue-resolution]
repository = "uuid-rs/uuid"
@@ -206,3 +200,4 @@
@@ -206,3 +195,4 @@
[badges.maintenance]
status = "actively-developed"

@ -1,5 +1,5 @@
--- uuid-1.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.7.0/Cargo.toml 2024-01-30T12:40:26.586271+00:00
--- uuid-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ uuid-1.8.0/Cargo.toml 2024-03-19T19:42:03.438839+00:00
@@ -89,16 +89,6 @@
optional = true
default-features = false
@ -17,16 +17,12 @@
[dependencies.bytemuck]
version = "1.14.0"
features = ["derive"]
@@ -131,18 +121,6 @@
@@ -131,14 +121,6 @@
version = "2"
optional = true
-[dependencies.uuid-macro-internal]
-version = "1.7.0"
-optional = true
-
-[dependencies.wasm-bindgen]
-version = "0.2"
-version = "1.8.0"
-optional = true
-
-[dependencies.zerocopy]
@ -36,7 +32,7 @@
[dev-dependencies.bincode]
version = "1.0"
@@ -163,20 +141,11 @@
@@ -159,19 +141,11 @@
[features]
atomic = ["dep:atomic"]
@ -50,7 +46,6 @@
"dep:rand",
]
-js = [
- "dep:wasm-bindgen",
- "getrandom?/js",
-]
-macro-diagnostics = ["dep:uuid-macro-internal"]

Loading…
Cancel
Save