Update to version 1.8.1; Fixes RHBZ#2333570

epel10 imports/epel10/rust-tinyvec-1.8.1-1.el10
Fabio Valentini 1 month ago
parent 5da2fc260c
commit f87d422f08
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -10,3 +10,4 @@
/tinyvec-1.6.1.crate
/tinyvec-1.7.0.crate
/tinyvec-1.8.0.crate
/tinyvec-1.8.1.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 26
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate tinyvec
Name: rust-tinyvec
Version: 1.8.0
Version: 1.8.1
Release: %autorelease
Summary: 100% safe vec-like data structures

@ -1 +1 @@
SHA512 (tinyvec-1.8.0.crate) = b7b32e38229645965900f80f298685f13e6d13e58cfd6945409a6643ca9c9adc2621456956d5998ab9dd91c2db4ae79638b156ca0d9c7c5505023fd9b28414df
SHA512 (tinyvec-1.8.1.crate) = db32a6beb1c86eb3e9f5ff2732a4acc03d1d684f0e54df5de2ecbfd08399639f47396ae8b17eb5f0122a09ba0c313f39bd73a6f7c44cc38d1891d1bdf3f2d176

@ -1,7 +1,7 @@
--- tinyvec-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tinyvec-1.8.0/Cargo.toml 2024-08-09T13:09:16.202528+00:00
@@ -77,29 +77,8 @@
]
--- tinyvec-1.8.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tinyvec-1.8.1/Cargo.toml 2025-01-03T16:50:32.945307+00:00
@@ -73,32 +73,11 @@
path = "tests/arrayvec.rs"
[[test]]
-name = "debugger_visualizer"
@ -10,8 +10,12 @@
-required-features = ["debugger_visualizer"]
-
-[[test]]
name = "arrayvec"
path = "tests/arrayvec.rs"
name = "tinyvec"
path = "tests/tinyvec.rs"
required-features = [
"alloc",
"std",
-]
-
-[[bench]]
-name = "macros"
@ -26,10 +30,9 @@
-required-features = [
- "alloc",
- "real_blackbox",
-]
]
[dependencies.arbitrary]
version = "1"
@@ -114,15 +93,6 @@
version = "0.1"
optional = true
@ -57,5 +60,5 @@
nightly_slice_partition_dedup = []
-real_blackbox = ["criterion/real_blackbox"]
rustc_1_40 = []
rustc_1_55 = []
rustc_1_55 = ["rustc_1_40"]
rustc_1_57 = ["rustc_1_55"]

Loading…
Cancel
Save