|
|
@ -1,7 +1,7 @@
|
|
|
|
--- tinyvec-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
--- tinyvec-1.8.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
+++ tinyvec-1.8.0/Cargo.toml 2024-08-09T13:09:16.202528+00:00
|
|
|
|
+++ tinyvec-1.8.1/Cargo.toml 2025-01-03T16:50:32.945307+00:00
|
|
|
|
@@ -77,29 +77,8 @@
|
|
|
|
@@ -73,32 +73,11 @@
|
|
|
|
]
|
|
|
|
path = "tests/arrayvec.rs"
|
|
|
|
|
|
|
|
|
|
|
|
[[test]]
|
|
|
|
[[test]]
|
|
|
|
-name = "debugger_visualizer"
|
|
|
|
-name = "debugger_visualizer"
|
|
|
@ -10,8 +10,12 @@
|
|
|
|
-required-features = ["debugger_visualizer"]
|
|
|
|
-required-features = ["debugger_visualizer"]
|
|
|
|
-
|
|
|
|
-
|
|
|
|
-[[test]]
|
|
|
|
-[[test]]
|
|
|
|
name = "arrayvec"
|
|
|
|
name = "tinyvec"
|
|
|
|
path = "tests/arrayvec.rs"
|
|
|
|
path = "tests/tinyvec.rs"
|
|
|
|
|
|
|
|
required-features = [
|
|
|
|
|
|
|
|
"alloc",
|
|
|
|
|
|
|
|
"std",
|
|
|
|
|
|
|
|
-]
|
|
|
|
-
|
|
|
|
-
|
|
|
|
-[[bench]]
|
|
|
|
-[[bench]]
|
|
|
|
-name = "macros"
|
|
|
|
-name = "macros"
|
|
|
@ -26,10 +30,9 @@
|
|
|
|
-required-features = [
|
|
|
|
-required-features = [
|
|
|
|
- "alloc",
|
|
|
|
- "alloc",
|
|
|
|
- "real_blackbox",
|
|
|
|
- "real_blackbox",
|
|
|
|
-]
|
|
|
|
]
|
|
|
|
|
|
|
|
|
|
|
|
[dependencies.arbitrary]
|
|
|
|
[dependencies.arbitrary]
|
|
|
|
version = "1"
|
|
|
|
|
|
|
|
@@ -114,15 +93,6 @@
|
|
|
|
@@ -114,15 +93,6 @@
|
|
|
|
version = "0.1"
|
|
|
|
version = "0.1"
|
|
|
|
optional = true
|
|
|
|
optional = true
|
|
|
@ -57,5 +60,5 @@
|
|
|
|
nightly_slice_partition_dedup = []
|
|
|
|
nightly_slice_partition_dedup = []
|
|
|
|
-real_blackbox = ["criterion/real_blackbox"]
|
|
|
|
-real_blackbox = ["criterion/real_blackbox"]
|
|
|
|
rustc_1_40 = []
|
|
|
|
rustc_1_40 = []
|
|
|
|
rustc_1_55 = []
|
|
|
|
rustc_1_55 = ["rustc_1_40"]
|
|
|
|
rustc_1_57 = ["rustc_1_55"]
|
|
|
|
rustc_1_57 = ["rustc_1_55"]
|
|
|
|