Initial import (#1999251)
parent
51f4d40a98
commit
39ca5d3dce
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/test-case-1.2.0.crate
|
@ -0,0 +1,93 @@
|
||||
# Generated by rust2rpm 18
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate test-case
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 1.2.0
|
||||
Release: %autorelease
|
||||
Summary: Procedural macro attribute for generating parametrized test cases
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/test-case
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop acceptance tests that are not included in published crates
|
||||
# * exclude some files that are only useful for upstream development
|
||||
Patch0: test-case-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Provides #[test_case(...)] procedural macro attribute for generating
|
||||
parametrized test cases easily.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hamcrest_assertions-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hamcrest_assertions-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "hamcrest_assertions" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hamcrest_assertions-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
# integration tests rely on files that are not included in published crates
|
||||
rm tests/acceptance_tests.rs
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (test-case-1.2.0.crate) = dfa9ae760fd36e951d9400705d8435decb5e3518812f830cd462f89e951089ed38a71319f7e697904761db094c3a505f01f3eb8aaba0665c42ad5ab5eaa632f7
|
@ -0,0 +1,21 @@
|
||||
--- test-case-1.2.0/Cargo.toml 2021-06-27T09:59:46+00:00
|
||||
+++ test-case-1.2.0/Cargo.toml 2021-08-29T22:28:23.811117+00:00
|
||||
@@ -16,7 +16,7 @@
|
||||
version = "1.2.0"
|
||||
authors = ["Marcin Sas-Szymanski <marcin.sas-szymanski@anixe.pl>", "Wojciech Polak <frondeus@gmail.com>", "Łukasz Biel <lukasz.p.biel@gmail.com>"]
|
||||
build = "build.rs"
|
||||
-exclude = ["tests/snapshots/**/*"]
|
||||
+exclude = ["/ci", "/publish.sh", "README.tpl", "tests/snapshots/**/*"]
|
||||
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
|
||||
documentation = "https://docs.rs/test-case"
|
||||
readme = "README.md"
|
||||
@@ -30,9 +30,6 @@
|
||||
doctest = false
|
||||
proc-macro = true
|
||||
|
||||
-[[test]]
|
||||
-name = "acceptance"
|
||||
-path = "tests/acceptance_tests.rs"
|
||||
[dependencies.cfg-if]
|
||||
version = "1.0.0"
|
||||
|
Loading…
Reference in new issue