Adapt to new packaging

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 3d9408739d
commit 7c62e64aa1
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -7,35 +7,78 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.3.1 Version: 0.3.1
Release: 5%{?dist} Release: 6%{?dist}
Summary: Functions for determining terminal sizes and dimensions Summary: Functions for determining terminal sizes and dimensions
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/term_size URL: https://crates.io/crates/term_size
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * clippy is nightly # * clippy is nightly
# * No windows # * No windows
Patch0: term_size-0.3.1-fix-metadata.diff # * Exclude useless files, https://github.com/clap-rs/term_size-rs/pull/22
Patch0: term_size-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
# [dependencies] BuildRequires: (crate(libc/default) >= 0.2.20 with crate(libc/default) < 0.3.0)
BuildRequires: (crate(libc) >= 0.2.20 with crate(libc) < 0.3.0)
%description %global _description \
%{summary}. Functions for determining terminal sizes and dimensions.
%description %{_description}
%package devel %package devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description devel %description devel %{_description}
Functions for determining terminal sizes and dimensions.
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md CONTRIBUTORS.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use %{crate} from crates.io. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+debug-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+debug-devel %{_description}
This package contains library source intended for building other packages
which use "debug" feature of "%{crate}" crate.
%files -n %{name}+debug-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unstable-devel %{_description}
This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version} -p1
@ -52,13 +95,10 @@ which use %{crate} from crates.io.
%cargo_test %cargo_test
%endif %endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md CONTRIBUTORS.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,index.html,justfile}
%changelog %changelog
* Sat Oct 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-6
- Adapt to new packaging
* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-5 * Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-5
- Run tests in infrastructure - Run tests in infrastructure

@ -1,6 +1,15 @@
--- term_size-0.3.1/Cargo.toml 1970-01-01T01:00:00+01:00 --- term_size-0.3.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ term_size-0.3.1/Cargo.toml 2017-11-15T07:04:57.415123+01:00 +++ term_size-0.3.1/Cargo.toml 2018-10-27T12:26:53.038444+02:00
@@ -59,24 +59,15 @@ @@ -14,7 +14,7 @@
name = "term_size"
version = "0.3.1"
authors = ["Kevin K. <kbknapp@gmail.com>", "Benjamin Sago <ogham@bsago.me>"]
-exclude = []
+exclude = ["/.clog.toml", "/.travis.yml", "/appveyor.yml", "/index.html", "/justfile"]
description = "functions for determining terminal sizes and dimensions"
documentation = "https://kbknapp.github.io/term_size-rs"
readme = "README.md"
@@ -59,24 +59,13 @@
debug = false debug = false
debug-assertions = false debug-assertions = false
rpath = false rpath = false
@ -12,14 +21,14 @@
debug = [] debug = []
default = [] default = []
-lints = ["clippy", "nightly"] -lints = ["clippy", "nightly"]
nightly = [] -nightly = []
-travis = ["lints", "nightly"] -travis = ["lints", "nightly"]
unstable = [] unstable = []
[target."cfg(not(target_os = \"windows\"))".dependencies.libc] [target."cfg(not(target_os = \"windows\"))".dependencies.libc]
version = "~0.2.20" version = "~0.2.20"
-[target."cfg(target_os = \"windows\")".dependencies.kernel32-sys] -[target."cfg(target_os = \"windows\")".dependencies.kernel32-sys]
-version = "~0.2.2" -version = "~0.2.2"
-
-[target."cfg(target_os = \"windows\")".dependencies.winapi] -[target."cfg(target_os = \"windows\")".dependencies.winapi]
-version = "~0.2.8" -version = "~0.2.8"
[badges.appveyor] [badges.appveyor]
Loading…
Cancel
Save