Update to version 0.6.7

epel10
Fabio Valentini 8 months ago
parent de30756c10
commit 8be8f457e3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/snapbox-0.4.14.crate
/snapbox-0.4.15.crate
/snapbox-0.4.16.crate
/snapbox-0.6.7.crate

@ -1,11 +1,14 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
# prevent executables from being installed
%global cargo_install_bin 0
%global crate snapbox
Name: rust-snapbox
Version: 0.4.16
Version: 0.6.7
Release: %autorelease
Summary: Snapshot testing toolbox
@ -14,11 +17,8 @@ URL: https://crates.io/crates/snapbox
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: snapbox-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * prevent test-only snap-fixture binary from being built and shipped
Patch: snapbox-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
BuildRequires: cargo-rpm-macros >= 26
%global _description %{expand:
Snapshot testing toolbox.}
@ -124,40 +124,40 @@ use the "diff" feature of the "%{crate}" crate.
%files -n %{name}+diff-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+document-features-devel
%package -n %{name}+dir-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+document-features-devel %{_description}
%description -n %{name}+dir-devel %{_description}
This package contains library source intended for building other packages which
use the "document-features" feature of the "%{crate}" crate.
use the "dir" feature of the "%{crate}" crate.
%files -n %{name}+document-features-devel
%files -n %{name}+dir-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+examples-devel
%package -n %{name}+document-features-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+examples-devel %{_description}
%description -n %{name}+document-features-devel %{_description}
This package contains library source intended for building other packages which
use the "examples" feature of the "%{crate}" crate.
use the "document-features" feature of the "%{crate}" crate.
%files -n %{name}+examples-devel
%files -n %{name}+document-features-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+harness-devel
%package -n %{name}+examples-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+harness-devel %{_description}
%description -n %{name}+examples-devel %{_description}
This package contains library source intended for building other packages which
use the "harness" feature of the "%{crate}" crate.
use the "examples" feature of the "%{crate}" crate.
%files -n %{name}+harness-devel
%files -n %{name}+examples-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+json-devel
@ -184,6 +184,18 @@ use the "path" feature of the "%{crate}" crate.
%files -n %{name}+path-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+structured-data-devel
Summary: %{summary}
BuildArch: noarch
@ -196,6 +208,18 @@ use the "structured-data" feature of the "%{crate}" crate.
%files -n %{name}+structured-data-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+term-svg-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+term-svg-devel %{_description}
This package contains library source intended for building other packages which
use the "term-svg" feature of the "%{crate}" crate.
%files -n %{name}+term-svg-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

@ -0,0 +1,3 @@
[package]
cargo-install-bin = false

@ -1,6 +1,6 @@
--- snapbox-0.4.16/Cargo.toml 1970-01-01T00:00:01+00:00
+++ snapbox-0.4.16/Cargo.toml 2024-01-13T20:35:46.245052+00:00
@@ -165,7 +165,6 @@
--- snapbox-0.6.7/Cargo.toml 1970-01-01T00:00:01+00:00
+++ snapbox-0.6.7/Cargo.toml 2024-06-04T13:09:32.031039+00:00
@@ -174,7 +174,6 @@
"dep:os_pipe",
"dep:wait-timeout",
"dep:libc",
@ -8,11 +8,20 @@
]
color = [
"dep:anstream",
@@ -204,7 +203,3 @@
version = "0.2.137"
optional = true
@@ -214,11 +213,6 @@
[target."cfg(unix)".dependencies.libc]
version = "0.2.137"
-optional = true
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.52.0"
-features = ["Win32_Foundation"]
-optional = true
optional = true
[lints.clippy]
@@ -287,3 +281,4 @@
unused_lifetimes = "warn"
unused_macro_rules = "warn"
unused_qualifications = "warn"
+

@ -1,20 +0,0 @@
--- snapbox-0.4.16/Cargo.toml 1970-01-01T00:00:01+00:00
+++ snapbox-0.4.16/Cargo.toml 2024-01-13T20:35:55.114092+00:00
@@ -36,6 +36,7 @@
categories = ["development-tools::testing"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/assert-rs/trycmd/"
+autobins = false
[package.metadata.docs.rs]
all-features = true
@@ -82,9 +83,6 @@
<!-- next-url -->
[Unreleased]: https://github.com/assert-rs/trycmd/compare/{{tag_name}}...HEAD"""
search = "<!-- next-url -->"
-
-[[bin]]
-name = "snap-fixture"
[[example]]
name = "diff"

@ -1 +1 @@
SHA512 (snapbox-0.4.16.crate) = 5433e10b4f6e427997cc8c058a40e45c5f5589b5d4a132505d2e6f7893312086f43f22a4b49d75b22b94bfc79e8505a00e4e864ba1bd059bf431e0ab2d9644fb
SHA512 (snapbox-0.6.7.crate) = 7945c82be74ef2dea9ca3cccc2c207facf1962dd6395cbab3e5ac21c954e499d965a0c7971cd74250be788da0269c5ee7ddb431ce957201c57f46e3f70ada658

Loading…
Cancel
Save