update to version 1.3.0

epel9
Fabio Valentini 4 years ago
parent 6dbd4048f1
commit a029204526
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/*.src.rpm
/sequoia-openpgp-1.1.0.crate
/sequoia-openpgp-1.3.0.crate

@ -1,13 +0,0 @@
diff --git a/src/types/timestamp.rs b/src/types/timestamp.rs
index c253efb..aeae1ab 100644
--- a/src/types/timestamp.rs
+++ b/src/types/timestamp.rs
@@ -682,7 +682,7 @@ mod tests {
UNIX_EPOCH + SystemDuration::new(i32::MAX as u64, 0));
let t3 = Timestamp::from(i32::MAX as u32 - 1);
- assert!(SystemTime::from(t3),
+ assert_eq!(SystemTime::from(t3),
UNIX_EPOCH + SystemDuration::new(i32::MAX as u64 - 1, 0));
Ok(())
}

@ -1,25 +1,22 @@
# Generated by rust2rpm 16
# Generated by rust2rpm 17
%bcond_without check
%global debug_package %{nil}
%global crate sequoia-openpgp
Name: rust-%{crate}
Version: 1.1.0
Release: 2%{?dist}
Version: 1.3.0
Release: 1%{?dist}
Summary: OpenPGP data types and associated machinery
# Upstream license specification: GPL-2.0-or-later
# https://gitlab.com/sequoia-pgp/sequoia/-/issues/708
License: GPLv2+
URL: https://crates.io/crates/sequoia-openpgp
Source: %{crates_source}
# Initial patched metadata
# * drop Windows-specific features and dependencies
# * drop features for vendoring nettle
# * drop benchmark-only criterion dev-dependency
Patch0: sequoia-openpgp-fix-metadata.diff
# https://gitlab.com/sequoia-pgp/sequoia/-/commit/eb371b84
Patch1: 0001-fix-typo-in-i686-tests.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -43,6 +40,7 @@ This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE.txt
%doc README.md NEWS
%{cargo_registry}/%{crate}-%{version_no_tilde}/
@ -161,6 +159,10 @@ which use "nettle" feature of "%{crate}" crate.
%endif
%changelog
* Tue Jun 22 2021 Fabio Valentini <decathorpe@gmail.com> - 1.3.0-1
- Update to version 1.3.0.
- Fixes RHBZ#1969381
* Mon Apr 12 2021 Fabio Valentini <decathorpe@gmail.com> - 1.1.0-2
- Add upstream patch to fix i686-specific test compilation failure.

@ -1,19 +1,26 @@
--- sequoia-openpgp-1.1.0/Cargo.toml 2021-03-05T14:30:52+00:00
+++ sequoia-openpgp-1.1.0/Cargo.toml 2021-03-31T10:13:04.415369+00:00
@@ -105,39 +105,14 @@
--- sequoia-openpgp-1.3.0/Cargo.toml 2021-06-08T09:54:24+00:00
+++ sequoia-openpgp-1.3.0/Cargo.toml 2021-06-22T10:03:03.567119+00:00
@@ -96,9 +96,6 @@
[dependencies.unicode-normalization]
version = "0.1.9"
-[dev-dependencies.criterion]
-version = "0.3.4"
-features = ["html_reports"]
[dev-dependencies.quickcheck]
version = "0.9"
@@ -117,37 +114,9 @@
compression = ["compression-deflate", "compression-bzip2"]
compression-bzip2 = ["bzip2", "buffered-reader/compression-bzip2"]
compression-deflate = ["flate2", "buffered-reader/compression-deflate"]
-crypto-cng = ["winapi", "win-crypto-ng", "ed25519-dalek", "num-bigint-dig"]
crypto-nettle = ["nettle"]
default = ["compression", "crypto-nettle"]
-vendored = ["vendored-nettle"]
-vendored-nettle = ["nettle/vendored"]
+
[target."cfg(all(target_arch = \"wasm32\", target_os = \"unknown\"))".dependencies.chrono]
version = "0.4.10"
features = ["std"]
default-features = false
-[target."cfg(all(target_arch = \"wasm32\", target_os = \"unknown\"))".dependencies.chrono]
-version = "0.4.10"
-features = ["std"]
-default-features = false
-[target."cfg(windows)".dependencies.eax]
-version = "0.3"

@ -1 +1 @@
SHA512 (sequoia-openpgp-1.1.0.crate) = abb7cd0a1602bd059b85e2c873729e51a26d0a4fa117bba5ab7e0e60087aa0bdfb1004c869e03d36d1681afe8384b08fa35da1ee6c9b44b1b24f3c646a0f702f
SHA512 (sequoia-openpgp-1.3.0.crate) = a2bcd06a0deafb7df151e07a55b86e2fa96ee95715b1480081b6dedcd20388ba7a000646ebcc827af16fd75675843ccd38c1f20232a05f2d0d8370de7b9e8c24

Loading…
Cancel
Save