import rust-schemars-0.8.21-3.el10

i10ce changed/i10ce/rust-schemars-0.8.21-3.el10
MSVSphere Packaging Team 2 months ago
commit 9dcf41ebb8
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/schemars-0.8.21.crate

@ -0,0 +1 @@
3789881606533025400c4c2ed09a19e5693b4f35 SOURCES/schemars-0.8.21.crate

@ -0,0 +1,11 @@
[package]
cargo-toml-patch-comments = [
"drop unused support for uuid v0.8",
]
[scripts]
prep.post = [
"# drop tests that pull in uuid v0.8",
"rm tests/uuid.rs",
]

@ -0,0 +1,34 @@
--- schemars-0.8.21/Cargo.toml 1970-01-01T00:00:01+00:00
+++ schemars-0.8.21/Cargo.toml 2024-09-16T00:20:05.928688+00:00
@@ -48,13 +48,6 @@
required-features = ["either"]
[[test]]
-name = "uuid"
-required-features = [
- "uuid08",
- "uuid1",
-]
-
-[[test]]
name = "smallvec"
required-features = ["smallvec"]
@@ -190,12 +183,6 @@
version = "2.0"
optional = true
default-features = false
-
-[dependencies.uuid08]
-version = "0.8"
-optional = true
-default-features = false
-package = "uuid"
[dependencies.uuid1]
version = "1.0"
@@ -220,4 +207,3 @@
preserve_order = ["indexmap"]
raw_value = ["serde_json/raw_value"]
ui_test = []
-uuid = ["uuid08"]

@ -0,0 +1,416 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 3;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate schemars
Name: rust-schemars
Version: 0.8.21
Release: %autorelease
Summary: Generate JSON Schemas from Rust code
License: MIT
URL: https://crates.io/crates/schemars
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused support for uuid v0.8
Patch: schemars-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Generate JSON Schemas from Rust code.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arrayvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arrayvec-devel %{_description}
This package contains library source intended for building other packages which
use the "arrayvec" feature of the "%{crate}" crate.
%files -n %{name}+arrayvec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arrayvec05-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arrayvec05-devel %{_description}
This package contains library source intended for building other packages which
use the "arrayvec05" feature of the "%{crate}" crate.
%files -n %{name}+arrayvec05-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arrayvec07-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arrayvec07-devel %{_description}
This package contains library source intended for building other packages which
use the "arrayvec07" feature of the "%{crate}" crate.
%files -n %{name}+arrayvec07-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bigdecimal-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bigdecimal-devel %{_description}
This package contains library source intended for building other packages which
use the "bigdecimal" feature of the "%{crate}" crate.
%files -n %{name}+bigdecimal-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bigdecimal03-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bigdecimal03-devel %{_description}
This package contains library source intended for building other packages which
use the "bigdecimal03" feature of the "%{crate}" crate.
%files -n %{name}+bigdecimal03-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bigdecimal04-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bigdecimal04-devel %{_description}
This package contains library source intended for building other packages which
use the "bigdecimal04" feature of the "%{crate}" crate.
%files -n %{name}+bigdecimal04-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytes-devel %{_description}
This package contains library source intended for building other packages which
use the "bytes" feature of the "%{crate}" crate.
%files -n %{name}+bytes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chrono-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chrono-devel %{_description}
This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+derive-devel %{_description}
This package contains library source intended for building other packages which
use the "derive" feature of the "%{crate}" crate.
%files -n %{name}+derive-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+derive_json_schema-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+derive_json_schema-devel %{_description}
This package contains library source intended for building other packages which
use the "derive_json_schema" feature of the "%{crate}" crate.
%files -n %{name}+derive_json_schema-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+either-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+either-devel %{_description}
This package contains library source intended for building other packages which
use the "either" feature of the "%{crate}" crate.
%files -n %{name}+either-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+enumset-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+enumset-devel %{_description}
This package contains library source intended for building other packages which
use the "enumset" feature of the "%{crate}" crate.
%files -n %{name}+enumset-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+impl_json_schema-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+impl_json_schema-devel %{_description}
This package contains library source intended for building other packages which
use the "impl_json_schema" feature of the "%{crate}" crate.
%files -n %{name}+impl_json_schema-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+indexmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+indexmap-devel %{_description}
This package contains library source intended for building other packages which
use the "indexmap" feature of the "%{crate}" crate.
%files -n %{name}+indexmap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+indexmap1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+indexmap1-devel %{_description}
This package contains library source intended for building other packages which
use the "indexmap1" feature of the "%{crate}" crate.
%files -n %{name}+indexmap1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+indexmap2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+indexmap2-devel %{_description}
This package contains library source intended for building other packages which
use the "indexmap2" feature of the "%{crate}" crate.
%files -n %{name}+indexmap2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+preserve_order-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+preserve_order-devel %{_description}
This package contains library source intended for building other packages which
use the "preserve_order" feature of the "%{crate}" crate.
%files -n %{name}+preserve_order-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+raw_value-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+raw_value-devel %{_description}
This package contains library source intended for building other packages which
use the "raw_value" feature of the "%{crate}" crate.
%files -n %{name}+raw_value-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rust_decimal-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rust_decimal-devel %{_description}
This package contains library source intended for building other packages which
use the "rust_decimal" feature of the "%{crate}" crate.
%files -n %{name}+rust_decimal-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+schemars_derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+schemars_derive-devel %{_description}
This package contains library source intended for building other packages which
use the "schemars_derive" feature of the "%{crate}" crate.
%files -n %{name}+schemars_derive-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+semver-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+semver-devel %{_description}
This package contains library source intended for building other packages which
use the "semver" feature of the "%{crate}" crate.
%files -n %{name}+semver-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smallvec-devel %{_description}
This package contains library source intended for building other packages which
use the "smallvec" feature of the "%{crate}" crate.
%files -n %{name}+smallvec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smol_str-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smol_str-devel %{_description}
This package contains library source intended for building other packages which
use the "smol_str" feature of the "%{crate}" crate.
%files -n %{name}+smol_str-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ui_test-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ui_test-devel %{_description}
This package contains library source intended for building other packages which
use the "ui_test" feature of the "%{crate}" crate.
%files -n %{name}+ui_test-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+url-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+url-devel %{_description}
This package contains library source intended for building other packages which
use the "url" feature of the "%{crate}" crate.
%files -n %{name}+url-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+uuid1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+uuid1-devel %{_description}
This package contains library source intended for building other packages which
use the "uuid1" feature of the "%{crate}" crate.
%files -n %{name}+uuid1-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# drop tests that pull in uuid v0.8
rm tests/uuid.rs
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.8.21-3
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Mon Sep 16 2024 Fabio Valentini <decathorpe@gmail.com> - 0.8.21-3
- Drop unused support for uuid v0.8
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.21-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Tue May 28 2024 Fabio Valentini <decathorpe@gmail.com> - 0.8.21-1
- Update to version 0.8.21; Fixes RHBZ#2281440
* Tue May 07 2024 Fabio Valentini <decathorpe@gmail.com> - 0.8.19-1
- Update to version 0.8.19; Fixes RHBZ#2277625
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.16-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Wed Nov 22 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.16-1
- Initial import (#2246014)
## END: Generated by rpmautospec
Loading…
Cancel
Save