Update to 0.26.1 Close: rhbz#1950008

epel9
Robert-André Mauchin 3 years ago
parent bb0c046e22
commit 131c4beb78

1
.gitignore vendored

@ -2,3 +2,4 @@
/*.src.rpm /*.src.rpm
/rusqlite-0.24.2.crate /rusqlite-0.24.2.crate
/rusqlite-0.26.1.crate

@ -1,28 +1,29 @@
--- rusqlite-0.24.2/Cargo.toml 1970-01-01T00:00:00+00:00 --- rusqlite-0.26.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rusqlite-0.24.2/Cargo.toml 2021-04-08T17:37:56.828728+00:00 +++ rusqlite-0.26.1/Cargo.toml 2021-11-13T11:21:24.207997+00:00
@@ -22,6 +22,8 @@ @@ -21,6 +21,7 @@
categories = ["database"] categories = ["database"]
license = "MIT" license = "MIT"
repository = "https://github.com/rusqlite/rusqlite" repository = "https://github.com/rusqlite/rusqlite"
+exclude = ["appveyor.yml", "clippy.toml", "codecov.yml", "publish-ghp-docs.sh", "test.csv"] +exclude = ["appveyor.yml", "clippy.toml", "codecov.yml", "publish-ghp-docs.sh", "test.csv"]
+
[package.metadata.docs.rs] [package.metadata.docs.rs]
all-features = false all-features = false
default-target = "x86_64-unknown-linux-gnu" default-target = "x86_64-unknown-linux-gnu"
@@ -132,9 +134,6 @@ @@ -135,11 +136,6 @@
backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"] backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"] blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"] buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
-bundled = ["libsqlite3-sys/bundled", "modern_sqlite"] -bundled = ["libsqlite3-sys/bundled", "modern_sqlite"]
-bundled-full = ["array", "backup", "blob", "bundled", "chrono", "collation", "column_decltype", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "trace", "unlock_notify", "url", "uuid", "vtab", "window"] -bundled-full = ["modern-full", "bundled"]
-bundled-sqlcipher = ["libsqlite3-sys/bundled-sqlcipher", "bundled"]
-bundled-sqlcipher-vendored-openssl = ["libsqlite3-sys/bundled-sqlcipher-vendored-openssl", "bundled-sqlcipher"]
-bundled-windows = ["libsqlite3-sys/bundled-windows"] -bundled-windows = ["libsqlite3-sys/bundled-windows"]
collation = [] collation = []
column_decltype = [] column_decltype = []
csvtab = ["csv", "vtab"] csvtab = ["csv", "vtab"]
@@ -145,16 +144,14 @@ @@ -151,16 +147,14 @@
in_gecko = ["modern_sqlite", "libsqlite3-sys/in_gecko"]
limits = [] limits = []
load_extension = [] load_extension = []
modern-full = ["array", "backup", "blob", "modern_sqlite", "chrono", "collation", "column_decltype", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "time", "trace", "unlock_notify", "url", "uuid", "vtab", "window"]
-modern_sqlite = ["libsqlite3-sys/bundled_bindings"] -modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
+modern_sqlite = [] +modern_sqlite = []
series = ["vtab"] series = ["vtab"]

@ -1,11 +1,11 @@
# Generated by rust2rpm 16 # Generated by rust2rpm 18
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rusqlite %global crate rusqlite
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.24.2 Version: 0.26.1
Release: %autorelease Release: %autorelease
Summary: Ergonomic wrapper for SQLite Summary: Ergonomic wrapper for SQLite
@ -273,6 +273,18 @@ which use "load_extension" feature of "%{crate}" crate.
%files -n %{name}+load_extension-devel %files -n %{name}+load_extension-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+modern-full-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+modern-full-devel %{_description}
This package contains library source intended for building other packages
which use "modern-full" feature of "%{crate}" crate.
%files -n %{name}+modern-full-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+modern_sqlite-devel %package -n %{name}+modern_sqlite-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -448,4 +460,4 @@ which use "with-asan" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
%autochangelog %autochangelog

@ -1 +1 @@
SHA512 (rusqlite-0.24.2.crate) = 47c7cd04c666fe42edcd667ecb3289c7a2b612446b2f95d78bf576fb691a167f372ec48e0d4cfbe973b32068b4f06e664d079fd3358a69fde895295a80d20caf SHA512 (rusqlite-0.26.1.crate) = 4322dbb58097324bdbcafa4dd81a3fb16c28a16b93091a371fbefd86aff5d2d104abd7290669f4092cc5cf869ccce794d4b20457b1a8ec7154a55c9a6c15cbea

Loading…
Cancel
Save