|
|
@ -1,28 +1,29 @@
|
|
|
|
--- rusqlite-0.24.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
|
|
|
--- rusqlite-0.26.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
+++ rusqlite-0.24.2/Cargo.toml 2021-04-08T17:37:56.828728+00:00
|
|
|
|
+++ rusqlite-0.26.1/Cargo.toml 2021-11-13T11:21:24.207997+00:00
|
|
|
|
@@ -22,6 +22,8 @@
|
|
|
|
@@ -21,6 +21,7 @@
|
|
|
|
categories = ["database"]
|
|
|
|
categories = ["database"]
|
|
|
|
license = "MIT"
|
|
|
|
license = "MIT"
|
|
|
|
repository = "https://github.com/rusqlite/rusqlite"
|
|
|
|
repository = "https://github.com/rusqlite/rusqlite"
|
|
|
|
+exclude = ["appveyor.yml", "clippy.toml", "codecov.yml", "publish-ghp-docs.sh", "test.csv"]
|
|
|
|
+exclude = ["appveyor.yml", "clippy.toml", "codecov.yml", "publish-ghp-docs.sh", "test.csv"]
|
|
|
|
+
|
|
|
|
|
|
|
|
[package.metadata.docs.rs]
|
|
|
|
[package.metadata.docs.rs]
|
|
|
|
all-features = false
|
|
|
|
all-features = false
|
|
|
|
default-target = "x86_64-unknown-linux-gnu"
|
|
|
|
default-target = "x86_64-unknown-linux-gnu"
|
|
|
|
@@ -132,9 +134,6 @@
|
|
|
|
@@ -135,11 +136,6 @@
|
|
|
|
backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
|
|
|
|
backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
|
|
|
|
blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
|
|
|
|
blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
|
|
|
|
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
|
|
|
|
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
|
|
|
|
-bundled = ["libsqlite3-sys/bundled", "modern_sqlite"]
|
|
|
|
-bundled = ["libsqlite3-sys/bundled", "modern_sqlite"]
|
|
|
|
-bundled-full = ["array", "backup", "blob", "bundled", "chrono", "collation", "column_decltype", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "trace", "unlock_notify", "url", "uuid", "vtab", "window"]
|
|
|
|
-bundled-full = ["modern-full", "bundled"]
|
|
|
|
|
|
|
|
-bundled-sqlcipher = ["libsqlite3-sys/bundled-sqlcipher", "bundled"]
|
|
|
|
|
|
|
|
-bundled-sqlcipher-vendored-openssl = ["libsqlite3-sys/bundled-sqlcipher-vendored-openssl", "bundled-sqlcipher"]
|
|
|
|
-bundled-windows = ["libsqlite3-sys/bundled-windows"]
|
|
|
|
-bundled-windows = ["libsqlite3-sys/bundled-windows"]
|
|
|
|
collation = []
|
|
|
|
collation = []
|
|
|
|
column_decltype = []
|
|
|
|
column_decltype = []
|
|
|
|
csvtab = ["csv", "vtab"]
|
|
|
|
csvtab = ["csv", "vtab"]
|
|
|
|
@@ -145,16 +144,14 @@
|
|
|
|
@@ -151,16 +147,14 @@
|
|
|
|
in_gecko = ["modern_sqlite", "libsqlite3-sys/in_gecko"]
|
|
|
|
|
|
|
|
limits = []
|
|
|
|
limits = []
|
|
|
|
load_extension = []
|
|
|
|
load_extension = []
|
|
|
|
|
|
|
|
modern-full = ["array", "backup", "blob", "modern_sqlite", "chrono", "collation", "column_decltype", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "time", "trace", "unlock_notify", "url", "uuid", "vtab", "window"]
|
|
|
|
-modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
|
|
|
|
-modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
|
|
|
|
+modern_sqlite = []
|
|
|
|
+modern_sqlite = []
|
|
|
|
series = ["vtab"]
|
|
|
|
series = ["vtab"]
|
|
|
|