parent
a32429ec09
commit
ff829fa40c
@ -0,0 +1,81 @@
|
|||||||
|
--- rkyv-0.7.45/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ rkyv-0.7.45/Cargo.toml 2024-08-30T19:01:30.121523+00:00
|
||||||
|
@@ -47,29 +47,14 @@
|
||||||
|
optional = true
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
-[dependencies.bitvec]
|
||||||
|
-version = "1.0"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
[dependencies.bytecheck]
|
||||||
|
version = "0.6.11"
|
||||||
|
optional = true
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
-[dependencies.bytes]
|
||||||
|
-version = "1.4.0"
|
||||||
|
+[dependencies.hashbrown]
|
||||||
|
+version = "0.14"
|
||||||
|
optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
-[dependencies.hashbrown]
|
||||||
|
-version = "0.12"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[dependencies.indexmap]
|
||||||
|
-version = "1.7"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
|
||||||
|
[dependencies.ptr_meta]
|
||||||
|
version = "~0.1.3"
|
||||||
|
@@ -86,31 +71,9 @@
|
||||||
|
[dependencies.seahash]
|
||||||
|
version = "4.0"
|
||||||
|
|
||||||
|
-[dependencies.smallvec]
|
||||||
|
-version = "1.7"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
-[dependencies.smol_str]
|
||||||
|
-version = "0.2"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
-[dependencies.tinyvec]
|
||||||
|
-version = "1.5"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
-[dependencies.uuid]
|
||||||
|
-version = "1.3"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
[features]
|
||||||
|
alloc = [
|
||||||
|
"hashbrown",
|
||||||
|
- "bitvec?/alloc",
|
||||||
|
- "tinyvec?/alloc",
|
||||||
|
]
|
||||||
|
arbitrary_enum_discriminant = ["rkyv_derive/arbitrary_enum_discriminant"]
|
||||||
|
archive_be = [
|
||||||
|
@@ -135,14 +98,8 @@
|
||||||
|
"bytecheck?/std",
|
||||||
|
"ptr_meta/std",
|
||||||
|
"rend?/std",
|
||||||
|
- "uuid?/std",
|
||||||
|
- "bytes?/std",
|
||||||
|
]
|
||||||
|
strict = ["rkyv_derive/strict"]
|
||||||
|
-uuid = [
|
||||||
|
- "dep:uuid",
|
||||||
|
- "bytecheck?/uuid",
|
||||||
|
-]
|
||||||
|
validation = [
|
||||||
|
"alloc",
|
||||||
|
"bytecheck",
|
@ -0,0 +1,6 @@
|
|||||||
|
[package]
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"bump hashbrown dependency from 0.12 to 0.14",
|
||||||
|
"drop unused support for various third-party crates",
|
||||||
|
]
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (rkyv-0.7.44.crate) = 8401efd3bd442862b6c4c62f22289191ca9cddab8d67dd6361c9f5722e4265c1a3941be20108822480fae8d567e7b2b0ce1d66200fbc5931d775225e9d6735b6
|
SHA512 (rkyv-0.7.45.crate) = bac10c6e7e7f797e505cc8103c55ae2fd4b04a76631e085fcf1c8f2b05e52c064cb14145479dadc292995b7ca5bbab5235d54d8e651bf47623a0228f936f73c9
|
||||||
|
Loading…
Reference in new issue