You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rkyv/rkyv-fix-metadata.diff

82 lines
1.5 KiB

--- rkyv-0.7.45/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rkyv-0.7.45/Cargo.toml 2024-08-30T19:01:30.121523+00:00
@@ -47,29 +47,14 @@
optional = true
default-features = false
-[dependencies.bitvec]
-version = "1.0"
-optional = true
-default-features = false
-
[dependencies.bytecheck]
version = "0.6.11"
optional = true
default-features = false
-[dependencies.bytes]
-version = "1.4.0"
+[dependencies.hashbrown]
+version = "0.14"
optional = true
-default-features = false
-
-[dependencies.hashbrown]
-version = "0.12"
-optional = true
-
-[dependencies.indexmap]
-version = "1.7"
-optional = true
-default-features = false
[dependencies.ptr_meta]
version = "~0.1.3"
@@ -86,31 +71,9 @@
[dependencies.seahash]
version = "4.0"
-[dependencies.smallvec]
-version = "1.7"
-optional = true
-default-features = false
-
-[dependencies.smol_str]
-version = "0.2"
-optional = true
-default-features = false
-
-[dependencies.tinyvec]
-version = "1.5"
-optional = true
-default-features = false
-
-[dependencies.uuid]
-version = "1.3"
-optional = true
-default-features = false
-
[features]
alloc = [
"hashbrown",
- "bitvec?/alloc",
- "tinyvec?/alloc",
]
arbitrary_enum_discriminant = ["rkyv_derive/arbitrary_enum_discriminant"]
archive_be = [
@@ -135,14 +98,8 @@
"bytecheck?/std",
"ptr_meta/std",
"rend?/std",
- "uuid?/std",
- "bytes?/std",
]
strict = ["rkyv_derive/strict"]
-uuid = [
- "dep:uuid",
- "bytecheck?/uuid",
-]
validation = [
"alloc",
"bytecheck",