update to version 0.10.9

epel9
Fabio Valentini 4 years ago
parent 5e0faba983
commit cbd856fdca
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -10,3 +10,4 @@
/reqwest-0.10.4.crate /reqwest-0.10.4.crate
/reqwest-0.10.6.crate /reqwest-0.10.6.crate
/reqwest-0.10.8.crate /reqwest-0.10.8.crate
/reqwest-0.10.9.crate

@ -0,0 +1,13 @@
[DEFAULT]
unwanted-features =
__rustls
hyper-rustls
native-tls-vendored
rustls
rustls-native-certs
rustls-tls
rustls-tls-manual-roots
rustls-tls-webpki-roots
rustls-tls-native-roots
tokio-rustls
webpki-roots

@ -1,38 +1,24 @@
--- reqwest-0.10.8/Cargo.toml 2020-08-25T16:30:15+00:00 --- reqwest-0.10.9/Cargo.toml 2020-11-20T00:04:44+00:00
+++ reqwest-0.10.8/Cargo.toml 2020-10-21T18:24:19.387172+00:00 +++ reqwest-0.10.9/Cargo.toml 2020-11-20T11:13:26.629492+00:00
@@ -102,7 +102,6 @@ @@ -251,21 +251,3 @@
gzip = ["async-compression", "async-compression/gzip"]
json = ["serde_json"]
native-tls = ["default-tls"]
-native-tls-vendored = ["native-tls", "native-tls-crate/vendored"]
rustls-tls = ["hyper-rustls", "tokio-rustls", "webpki-roots", "rustls", "__tls"]
socks = ["tokio-socks"]
stream = []
@@ -195,7 +194,7 @@
optional = true
[target."cfg(not(target_arch = \"wasm32\"))".dependencies.tokio-socks]
-version = "0.2"
+version = "0.3"
optional = true
[target."cfg(not(target_arch = \"wasm32\"))".dependencies.tokio-tls]
@@ -235,18 +234,3 @@
version = "0.2.0" version = "0.2.0"
features = ["macros"] features = ["macros"]
default-features = false default-features = false
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys] -[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
-version = "0.3.28" -version = "0.3.45"
- -
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen] -[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen]
-version = "0.2.51" -version = "0.2.68"
-features = ["serde-serialize"] -features = ["serde-serialize"]
- -
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-futures] -[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-futures]
-version = "0.4.1" -version = "0.4.18"
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-test]
-version = "0.3"
- -
-[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys] -[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
-version = "0.3.25" -version = "0.3.25"
-features = ["Headers", "Request", "RequestInit", "RequestMode", "Response", "Window", "FormData", "Blob", "BlobPropertyBag"] -features = ["Headers", "Request", "RequestInit", "RequestMode", "Response", "Window", "FormData", "Blob", "BlobPropertyBag", "ServiceWorkerGlobalScope"]
-[target."cfg(windows)".dependencies.winreg] -[target."cfg(windows)".dependencies.winreg]
-version = "0.7" -version = "0.7"

@ -1,12 +1,12 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 16
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate reqwest %global crate reqwest
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.10.8 Version: 0.10.9
Release: 2%{?dist} Release: 1%{?dist}
Summary: Higher level HTTP client library Summary: Higher level HTTP client library
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
@ -15,8 +15,6 @@ URL: https://crates.io/crates/reqwest
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No windows/wasm32 # * No windows/wasm32
# * Bump tokio-socks from 0.2 to 0.3:
# https://github.com/seanmonstar/reqwest/commit/d42d16c
Patch0: reqwest-fix-metadata.diff Patch0: reqwest-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -177,18 +175,6 @@ which use "gzip" feature of "%{crate}" crate.
%files -n %{name}+gzip-devel %files -n %{name}+gzip-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+hyper-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-rustls-devel %{_description}
This package contains library source intended for building other packages
which use "hyper-rustls" feature of "%{crate}" crate.
%files -n %{name}+hyper-rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+hyper-tls-devel %package -n %{name}+hyper-tls-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -237,30 +223,6 @@ which use "native-tls-crate" feature of "%{crate}" crate.
%files -n %{name}+native-tls-crate-devel %files -n %{name}+native-tls-crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-devel %{_description}
This package contains library source intended for building other packages
which use "rustls" feature of "%{crate}" crate.
%files -n %{name}+rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-devel %{_description}
This package contains library source intended for building other packages
which use "rustls-tls" feature of "%{crate}" crate.
%files -n %{name}+rustls-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde_json-devel %package -n %{name}+serde_json-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -309,18 +271,6 @@ which use "time" feature of "%{crate}" crate.
%files -n %{name}+time-devel %files -n %{name}+time-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-rustls-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-rustls" feature of "%{crate}" crate.
%files -n %{name}+tokio-rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-socks-devel %package -n %{name}+tokio-socks-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -369,18 +319,6 @@ which use "trust-dns-resolver" feature of "%{crate}" crate.
%files -n %{name}+trust-dns-resolver-devel %files -n %{name}+trust-dns-resolver-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+webpki-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+webpki-roots-devel %{_description}
This package contains library source intended for building other packages
which use "webpki-roots" feature of "%{crate}" crate.
%files -n %{name}+webpki-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
@ -401,6 +339,9 @@ which use "webpki-roots" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Fri Nov 27 2020 Fabio Valentini <decathorpe@gmail.com> - 0.10.9-1
- Update to version 0.10.9.
* Wed Oct 21 2020 Fabio Valentini <decathorpe@gmail.com> - 0.10.8-2 * Wed Oct 21 2020 Fabio Valentini <decathorpe@gmail.com> - 0.10.8-2
- Bump to tokio-socks 0.3. - Bump to tokio-socks 0.3.

@ -1 +1 @@
SHA512 (reqwest-0.10.8.crate) = aac1df2e57096b85bf963bf9473d676fffdd524c4d4738c2c79f6a2e277e69ec8f896eddbb809a5ed0fd32f05a61320ce259b6d5dfc5262b8aa8cb678f9f76ce SHA512 (reqwest-0.10.9.crate) = c129314de154691dff132da7b58c8279183b1f96b6de14ad07105fd1cfcedefd819a26f2487dde184b93166ae11d4df001646d7a77227845bff849f753a6c52e

Loading…
Cancel
Save