import rust-reqwest-0.12.12-1.el10

i10ce changed/i10ce/rust-reqwest-0.12.12-1.el10
MSVSphere Packaging Team 1 month ago
parent 81ea4f927e
commit 241c7d657b
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

2
.gitignore vendored

@ -1 +1 @@
SOURCES/reqwest-0.12.9.crate SOURCES/reqwest-0.12.12.crate

@ -1 +1 @@
8d489379ab7c0e9b3348279a8a87522c78212604 SOURCES/reqwest-0.12.9.crate ba5ff9f835792d423c27feb2ea4a5955645f2284 SOURCES/reqwest-0.12.12.crate

@ -1,6 +1,6 @@
--- reqwest-0.12.9/Cargo.toml 1970-01-01T00:00:01+00:00 --- reqwest-0.12.12/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.12.9/Cargo.toml 2024-10-30T22:19:12.691722+00:00 +++ reqwest-0.12.12/Cargo.toml 2025-01-04T14:02:28.391991+00:00
@@ -285,7 +285,7 @@ @@ -132,7 +132,7 @@
"dep:futures-channel", "dep:futures-channel",
] ]
json = ["dep:serde_json"] json = ["dep:serde_json"]
@ -9,7 +9,7 @@
multipart = ["dep:mime_guess"] multipart = ["dep:mime_guess"]
native-tls = ["default-tls"] native-tls = ["default-tls"]
native-tls-alpn = [ native-tls-alpn = [
@@ -326,7 +326,6 @@ @@ -173,7 +173,6 @@
stream = [ stream = [
"tokio/fs", "tokio/fs",
"dep:tokio-util", "dep:tokio-util",
@ -17,7 +17,7 @@
] ]
trust-dns = [] trust-dns = []
zstd = [ zstd = [
@@ -566,57 +565,8 @@ @@ -593,57 +592,8 @@
version = "0.13" version = "0.13"
package = "zstd" package = "zstd"

@ -1,32 +1,6 @@
--- reqwest-0.12.9/Cargo.toml 1970-01-01T00:00:01+00:00 --- reqwest-0.12.12/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.12.9/Cargo.toml 2024-10-30T22:21:02.376394+00:00 +++ reqwest-0.12.12/Cargo.toml 2025-01-04T14:04:13.275543+00:00
@@ -71,10 +71,6 @@ @@ -71,7 +71,6 @@
path = "examples/form.rs"
[[example]]
-name = "h3_simple"
-path = "examples/h3_simple.rs"
-
-[[example]]
name = "json_dynamic"
path = "examples/json_dynamic.rs"
required-features = ["json"]
@@ -101,14 +97,6 @@
name = "blocking"
path = "tests/blocking.rs"
required-features = ["blocking"]
-
-[[test]]
-name = "brotli"
-path = "tests/brotli.rs"
-required-features = [
- "brotli",
- "stream",
-]
[[test]]
name = "client"
@@ -224,7 +212,6 @@
"hyper-rustls?/ring", "hyper-rustls?/ring",
"tokio-rustls?/ring", "tokio-rustls?/ring",
"rustls?/ring", "rustls?/ring",
@ -34,7 +8,7 @@
] ]
__tls = [ __tls = [
"dep:rustls-pemfile", "dep:rustls-pemfile",
@@ -237,11 +224,6 @@ @@ -84,11 +83,6 @@
"futures-util/sink", "futures-util/sink",
"tokio/sync", "tokio/sync",
] ]
@ -46,7 +20,7 @@
charset = ["dep:encoding_rs"] charset = ["dep:encoding_rs"]
cookies = [ cookies = [
"dep:cookie_crate", "dep:cookie_crate",
@@ -251,7 +233,6 @@ @@ -98,7 +92,6 @@
"default-tls", "default-tls",
"charset", "charset",
"http2", "http2",
@ -54,7 +28,7 @@
] ]
default-tls = [ default-tls = [
"dep:hyper-tls", "dep:hyper-tls",
@@ -276,16 +257,7 @@ @@ -123,16 +116,7 @@
"hyper-util/http2", "hyper-util/http2",
"hyper-rustls?/http2", "hyper-rustls?/http2",
] ]
@ -71,7 +45,7 @@
multipart = ["dep:mime_guess"] multipart = ["dep:mime_guess"]
native-tls = ["default-tls"] native-tls = ["default-tls"]
native-tls-alpn = [ native-tls-alpn = [
@@ -293,10 +265,6 @@ @@ -140,10 +124,6 @@
"native-tls-crate?/alpn", "native-tls-crate?/alpn",
"hyper-tls?/alpn", "hyper-tls?/alpn",
] ]
@ -82,7 +56,33 @@
rustls-tls = ["rustls-tls-webpki-roots"] rustls-tls = ["rustls-tls-webpki-roots"]
rustls-tls-manual-roots = [ rustls-tls-manual-roots = [
"rustls-tls-manual-roots-no-provider", "rustls-tls-manual-roots-no-provider",
@@ -361,14 +329,6 @@ @@ -199,10 +179,6 @@
path = "examples/form.rs"
[[example]]
-name = "h3_simple"
-path = "examples/h3_simple.rs"
-
-[[example]]
name = "json_dynamic"
path = "examples/json_dynamic.rs"
required-features = ["json"]
@@ -229,14 +205,6 @@
name = "blocking"
path = "tests/blocking.rs"
required-features = ["blocking"]
-
-[[test]]
-name = "brotli"
-path = "tests/brotli.rs"
-required-features = [
- "brotli",
- "stream",
-]
[[test]]
name = "client"
@@ -380,14 +348,6 @@
version = "0.4" version = "0.4"
optional = true optional = true
@ -97,7 +97,7 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.hickory-resolver] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.hickory-resolver]
version = "0.24" version = "0.24"
features = ["tokio-runtime"] features = ["tokio-runtime"]
@@ -432,15 +392,6 @@ @@ -451,15 +411,6 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.pin-project-lite] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.pin-project-lite]
version = "0.2.11" version = "0.2.11"
@ -113,7 +113,7 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.rustls] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.rustls]
version = "0.23.4" version = "0.23.4"
features = [ features = [
@@ -501,10 +452,6 @@ @@ -528,10 +479,6 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.webpki-roots] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.webpki-roots]
version = "0.26.0" version = "0.26.0"
optional = true optional = true

@ -2,20 +2,20 @@
## (rpmautospec version 0.7.3) ## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog ## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua: %define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 2; release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}")); base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1); print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}} }%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec ## END: Set by rpmautospec
# Generated by rust2rpm 26 # Generated by rust2rpm 27
%bcond_without check %bcond check 1
%global debug_package %{nil} %global debug_package %{nil}
%global crate reqwest %global crate reqwest
Name: rust-reqwest Name: rust-reqwest
Version: 0.12.9 Version: 0.12.12
Release: %autorelease Release: %autorelease
Summary: Higher level HTTP client library Summary: Higher level HTTP client library
@ -442,17 +442,23 @@ rm tests/brotli.rs
%if %{with check} %if %{with check}
%check %check
# * run tests single-threaded to avoid clobbered environment variables:
# https://github.com/seanmonstar/reqwest/issues/2468
# * skip tests which require internet access # * skip tests which require internet access
%cargo_test -- -- --test-threads 1 --exact --skip test_allowed_methods --skip test_badssl_modern --skip test_badssl_self_signed --skip test_tls_info %{cargo_test -- -- --exact %{shrink:
--skip test_allowed_methods
--skip test_badssl_modern
--skip test_badssl_self_signed
--skip test_tls_info
}}
%endif %endif
%changelog %changelog
## START: Generated by rpmautospec
* Sat Jan 04 2025 Fabio Valentini <decathorpe@gmail.com> - 0.12.12-1
- Update to version 0.12.12; Fixes RHBZ#2334233
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.12.9-2 * Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.12.9-2
- Rebuilt for MSVSphere 10 - Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Mon Nov 04 2024 Fabio Valentini <decathorpe@gmail.com> - 0.12.9-2 * Mon Nov 04 2024 Fabio Valentini <decathorpe@gmail.com> - 0.12.9-2
- Run tests single-threaded to avoid clobbered environment variables - Run tests single-threaded to avoid clobbered environment variables

Loading…
Cancel
Save