Update to version 0.8.2; Fixes RHBZ#2173156

epel9 imports/e9/rust-remove_dir_all-0.8.2-1.el9
Fabio Valentini 1 year ago
parent 3e02c4d1a2
commit e5d1a74013
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/remove_dir_all-0.5.2.crate /remove_dir_all-0.5.2.crate
/remove_dir_all-0.5.3.crate /remove_dir_all-0.5.3.crate
/remove_dir_all-0.7.0.crate /remove_dir_all-0.7.0.crate
/remove_dir_all-0.8.2.crate

@ -1,18 +1,19 @@
--- remove_dir_all-0.7.0/Cargo.toml 1970-01-01T00:00:00+00:00 --- remove_dir_all-0.8.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ remove_dir_all-0.7.0/Cargo.toml 2023-05-25T19:03:22.357769+00:00 +++ remove_dir_all-0.8.2/Cargo.toml 2023-11-04T23:50:51.144272+00:00
@@ -32,15 +32,3 @@ @@ -101,16 +101,3 @@
version = "3.1"
[target."cfg(not(windows))".dependencies.libc] [target."cfg(not(windows))".dependencies.libc]
version = "0.2" version = "0.2"
-[target."cfg(windows)".dependencies.log]
-version = "0.4.11" -[target."cfg(windows)".dependencies.aligned]
-version = "0.4.1"
- -
-[target."cfg(windows)".dependencies.num_cpus] -[target."cfg(windows)".dependencies.windows-sys]
-version = "1.13" -version = "0.45.0"
- -features = [
-[target."cfg(windows)".dependencies.rayon] - "Win32_Foundation",
-version = "1.4" - "Win32_Storage_FileSystem",
- - "Win32_System_IO",
-[target."cfg(windows)".dependencies.winapi] - "Win32_System_Ioctl",
-version = "0.3" - "Win32_System_SystemServices",
-features = ["std", "errhandlingapi", "winerror", "fileapi", "winbase"] - "Win32_System_Threading",
-]

@ -0,0 +1,39 @@
--- remove_dir_all-0.8.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ remove_dir_all-0.8.2/Cargo.toml 2023-11-04T23:51:34.050434+00:00
@@ -35,22 +35,10 @@
categories = ["filesystem"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/XAMPPRocky/remove_dir_all.git"
-
-[[bin]]
-name = "remove-dir-all"
-required-features = ["cli"]
+autobins = false
[dependencies.cfg-if]
version = "1.0.0"
-
-[dependencies.clap]
-version = "4.1.11"
-features = ["derive"]
-optional = true
-
-[dependencies.env_logger]
-version = "0.10.0"
-optional = true
[dependencies.fs_at]
version = "0.1.4"
@@ -85,12 +73,6 @@
version = "0.2"
[features]
-cli = [
- "dep:clap",
- "dep:env_logger",
- "log",
- "parallel",
-]
default = []
log = ["dep:log"]
parallel = ["dep:rayon"]

@ -1,23 +1,24 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
# * tests seem to be broken with Rust 1.55+ %bcond_without check
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate remove_dir_all %global crate remove_dir_all
Name: rust-remove_dir_all Name: rust-remove_dir_all
Version: 0.7.0 Version: 0.8.2
Release: %autorelease Release: %autorelease
Summary: Safe, reliable implementation of remove_dir_all Summary: Safe, reliable implementation of remove_dir_all
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/remove_dir_all URL: https://crates.io/crates/remove_dir_all
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: remove_dir_all-fix-metadata-auto.diff Patch: remove_dir_all-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * prevent unused remove-dir-all executable from being built and shipped
Patch: remove_dir_all-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
A safe, reliable implementation of remove_dir_all for Windows.} A safe, reliable implementation of remove_dir_all for Windows.}
@ -51,8 +52,32 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parallel-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parallel-devel %{_description}
This package contains library source intended for building other packages which
use the "parallel" feature of the "%{crate}" crate.
%files -n %{name}+parallel-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -0,0 +1,3 @@
[package]
summary = "Safe, reliable implementation of remove_dir_all"

@ -1 +1 @@
SHA512 (remove_dir_all-0.7.0.crate) = a4a426e7f3e9f4d3925809e22ebb61d06be04703ecabbc07aae80894458f29a146bc6aa6540ab4ac96c74a160a5520ea079ebb6ac6cca489ba036ece6678339c SHA512 (remove_dir_all-0.8.2.crate) = db20998b6db76ead161b69ad4f92cc7139a67285b1d7cd7a3631b4c46450503b378a597d3e27c618dd5a4f77c0b3f20a25036ad495c88a9a1d134a6af58f0134

Loading…
Cancel
Save