parent
3e02c4d1a2
commit
e5d1a74013
@ -1,18 +1,19 @@
|
|||||||
--- remove_dir_all-0.7.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
--- remove_dir_all-0.8.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
+++ remove_dir_all-0.7.0/Cargo.toml 2023-05-25T19:03:22.357769+00:00
|
+++ remove_dir_all-0.8.2/Cargo.toml 2023-11-04T23:50:51.144272+00:00
|
||||||
@@ -32,15 +32,3 @@
|
@@ -101,16 +101,3 @@
|
||||||
version = "3.1"
|
|
||||||
[target."cfg(not(windows))".dependencies.libc]
|
[target."cfg(not(windows))".dependencies.libc]
|
||||||
version = "0.2"
|
version = "0.2"
|
||||||
-[target."cfg(windows)".dependencies.log]
|
|
||||||
-version = "0.4.11"
|
-[target."cfg(windows)".dependencies.aligned]
|
||||||
|
-version = "0.4.1"
|
||||||
-
|
-
|
||||||
-[target."cfg(windows)".dependencies.num_cpus]
|
-[target."cfg(windows)".dependencies.windows-sys]
|
||||||
-version = "1.13"
|
-version = "0.45.0"
|
||||||
-
|
-features = [
|
||||||
-[target."cfg(windows)".dependencies.rayon]
|
- "Win32_Foundation",
|
||||||
-version = "1.4"
|
- "Win32_Storage_FileSystem",
|
||||||
-
|
- "Win32_System_IO",
|
||||||
-[target."cfg(windows)".dependencies.winapi]
|
- "Win32_System_Ioctl",
|
||||||
-version = "0.3"
|
- "Win32_System_SystemServices",
|
||||||
-features = ["std", "errhandlingapi", "winerror", "fileapi", "winbase"]
|
- "Win32_System_Threading",
|
||||||
|
-]
|
||||||
|
@ -0,0 +1,39 @@
|
|||||||
|
--- remove_dir_all-0.8.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ remove_dir_all-0.8.2/Cargo.toml 2023-11-04T23:51:34.050434+00:00
|
||||||
|
@@ -35,22 +35,10 @@
|
||||||
|
categories = ["filesystem"]
|
||||||
|
license = "MIT OR Apache-2.0"
|
||||||
|
repository = "https://github.com/XAMPPRocky/remove_dir_all.git"
|
||||||
|
-
|
||||||
|
-[[bin]]
|
||||||
|
-name = "remove-dir-all"
|
||||||
|
-required-features = ["cli"]
|
||||||
|
+autobins = false
|
||||||
|
|
||||||
|
[dependencies.cfg-if]
|
||||||
|
version = "1.0.0"
|
||||||
|
-
|
||||||
|
-[dependencies.clap]
|
||||||
|
-version = "4.1.11"
|
||||||
|
-features = ["derive"]
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[dependencies.env_logger]
|
||||||
|
-version = "0.10.0"
|
||||||
|
-optional = true
|
||||||
|
|
||||||
|
[dependencies.fs_at]
|
||||||
|
version = "0.1.4"
|
||||||
|
@@ -85,12 +73,6 @@
|
||||||
|
version = "0.2"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-cli = [
|
||||||
|
- "dep:clap",
|
||||||
|
- "dep:env_logger",
|
||||||
|
- "log",
|
||||||
|
- "parallel",
|
||||||
|
-]
|
||||||
|
default = []
|
||||||
|
log = ["dep:log"]
|
||||||
|
parallel = ["dep:rayon"]
|
@ -0,0 +1,3 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Safe, reliable implementation of remove_dir_all"
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (remove_dir_all-0.7.0.crate) = a4a426e7f3e9f4d3925809e22ebb61d06be04703ecabbc07aae80894458f29a146bc6aa6540ab4ac96c74a160a5520ea079ebb6ac6cca489ba036ece6678339c
|
SHA512 (remove_dir_all-0.8.2.crate) = db20998b6db76ead161b69ad4f92cc7139a67285b1d7cd7a3631b4c46450503b378a597d3e27c618dd5a4f77c0b3f20a25036ad495c88a9a1d134a6af58f0134
|
||||||
|
Loading…
Reference in new issue