initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent ccd006d8e4
commit ae86f6484e

1
.gitignore vendored

@ -0,0 +1 @@
/regex-0.2.2.crate

@ -0,0 +1,27 @@
--- regex-0.2.2/Cargo.toml 2017-05-21T18:24:14+02:00
+++ regex-0.2.2/Cargo.toml 2017-11-08T23:27:36.884076+01:00
@@ -17,13 +17,11 @@
# For very fast prefix literal matching.
aho-corasick = "0.6.0"
# For skipping along search text quickly when a leading byte is known.
-memchr = "1.0.0"
+memchr = "2.0.0"
# For managing regex caches quickly across multiple threads.
thread_local = "0.3.2"
# For parsing regular expressions.
-regex-syntax = { path = "regex-syntax", version = "0.4.1" }
-# For accelerating text search.
-simd = { version = "0.1.1", optional = true }
+regex-syntax = { version = "0.4.1" }
# For compiling UTF-8 decoding into automata.
utf8-ranges = "1.0.0"
@@ -38,8 +36,6 @@
[features]
# Enable to use the unstable pattern traits defined in std.
pattern = []
-# Enable to use simd acceleration.
-simd-accel = ["simd"]
[lib]
# There are no benchmarks in the library code itself

@ -0,0 +1,84 @@
# Generated by rust2rpm
# regex(dev) -> quickcheck(opt) -> env_logger(opt) -> regex
%bcond_with check
%global debug_package %{nil}
%global crate regex
Name: rust-%{crate}
Version: 0.2.2
Release: 2%{?dist}
Summary: Implementation of regular expressions for Rust
License: MIT or ASL 2.0
URL: https://crates.io/crates/regex
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No path dependencies
# * simd is nightly
# * bump memchr to 2, https://github.com/rust-lang/regex/pull/415
Patch0: regex-0.2.2-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(aho-corasick) >= 0.6.0 with crate(aho-corasick) < 0.7.0)
BuildRequires: (crate(memchr) >= 2.0.0 with crate(memchr) < 3.0.0)
BuildRequires: (crate(regex-syntax) >= 0.4.1 with crate(regex-syntax) < 0.5.0)
BuildRequires: (crate(thread_local) >= 0.3.2 with crate(thread_local) < 0.4.0)
BuildRequires: (crate(utf8-ranges) >= 1.0.0 with crate(utf8-ranges) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(lazy_static) >= 0.2.2 with crate(lazy_static) < 0.3.0)
BuildRequires: (crate(quickcheck) >= 0.4.1 with crate(quickcheck) < 0.5.0)
BuildRequires: (crate(rand) >= 0.3.15 with crate(rand) < 0.4.0)
%endif
%description
%{summary}.
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
An implementation of regular expressions for Rust. This implementation uses
finite automata and guarantees linear time matching on all inputs.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md HACKING.md PERFORMANCE.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci,scripts}
%changelog
* Wed Nov 08 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-2
- Bump memchr to 2
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-2
- Port to use rust-packaging
* Sat Feb 25 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
- Initial package

@ -0,0 +1 @@
SHA512 (regex-0.2.2.crate) = 208b671d06b260e4a130718a86ced88ee7f183bd056461bc6d44a15a22260a9ee05a014682bdb8bb7ff674fd33ac4748687c7ebd847578c7fecc8efbbb1993b3
Loading…
Cancel
Save