You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-regex/regex-0.2.2-fix-metadata.diff

28 lines
907 B

--- regex-0.2.2/Cargo.toml 2017-05-21T18:24:14+02:00
+++ regex-0.2.2/Cargo.toml 2017-11-08T23:27:36.884076+01:00
@@ -17,13 +17,11 @@
# For very fast prefix literal matching.
aho-corasick = "0.6.0"
# For skipping along search text quickly when a leading byte is known.
-memchr = "1.0.0"
+memchr = "2.0.0"
# For managing regex caches quickly across multiple threads.
thread_local = "0.3.2"
# For parsing regular expressions.
-regex-syntax = { path = "regex-syntax", version = "0.4.1" }
-# For accelerating text search.
-simd = { version = "0.1.1", optional = true }
+regex-syntax = { version = "0.4.1" }
# For compiling UTF-8 decoding into automata.
utf8-ranges = "1.0.0"
@@ -38,8 +36,6 @@
[features]
# Enable to use the unstable pattern traits defined in std.
pattern = []
-# Enable to use simd acceleration.
-simd-accel = ["simd"]
[lib]
# There are no benchmarks in the library code itself