Update to 0.6.5

epel9
Josh Stone 6 years ago
parent af03082154
commit 7473d9d9de

1
.gitignore vendored

@ -7,3 +7,4 @@
/rand-0.5.5.crate
/rand-0.6.1.crate
/rand-0.6.4.crate
/rand-0.6.5.crate

@ -1,5 +1,5 @@
--- rand-0.6.4/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rand-0.6.4/Cargo.toml 2019-01-10T09:32:09.837209-08:00
--- rand-0.6.5/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rand-0.6.5/Cargo.toml 2019-01-28T14:27:08.386144-08:00
@@ -28,11 +28,6 @@
all-features = true
[dependencies.log]
@ -12,14 +12,14 @@
optional = true
[dependencies.rand_chacha]
@@ -69,18 +64,11 @@
@@ -71,18 +66,11 @@
alloc = ["rand_core/alloc"]
default = ["std", "rand_os"]
default = ["std"]
i128_support = []
-nightly = ["simd_support"]
serde1 = ["rand_core/serde1", "rand_isaac/serde1", "rand_xorshift/serde1"]
-simd_support = ["packed_simd"]
std = ["rand_core/std", "alloc", "rand_os"]
std = ["rand_core/std", "alloc", "rand_os", "rand_jitter/std"]
-stdweb = ["rand_os/stdweb"]
-wasm-bindgen = ["rand_os/wasm-bindgen"]
[target."cfg(unix)".dependencies.libc]

@ -7,7 +7,7 @@
Name: rust-%{crate}
Summary: Random number generators and other randomness functionality
Version: 0.6.4
Version: 0.6.5
Release: 1%{?dist}
# Upstream license specification: MIT/Apache-2.0
@ -15,7 +15,7 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/rand
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove non-unix dependencies
# * Remove non-unix dependencies and nightly features
Patch0: rand-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -25,13 +25,15 @@ BuildRequires: (crate(autocfg/default) >= 0.1.0 with crate(autocfg/default) < 0
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(rand_chacha/default) >= 0.1.0 with crate(rand_chacha/default) < 0.2.0)
BuildRequires: (crate(rand_core) >= 0.3.0 with crate(rand_core) < 0.4.0)
BuildRequires: (crate(rand_core/alloc) >= 0.3.0 with crate(rand_core/alloc) < 0.4.0)
BuildRequires: (crate(rand_core/serde1) >= 0.3.0 with crate(rand_core/serde1) < 0.4.0)
BuildRequires: (crate(rand_core/std) >= 0.3.0 with crate(rand_core/std) < 0.4.0)
BuildRequires: (crate(rand_core/alloc) >= 0.4.0 with crate(rand_core/alloc) < 0.5.0)
BuildRequires: (crate(rand_core/default) >= 0.4.0 with crate(rand_core/default) < 0.5.0)
BuildRequires: (crate(rand_core/serde1) >= 0.4.0 with crate(rand_core/serde1) < 0.5.0)
BuildRequires: (crate(rand_core/std) >= 0.4.0 with crate(rand_core/std) < 0.5.0)
BuildRequires: (crate(rand_hc/default) >= 0.1.0 with crate(rand_hc/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/default) >= 0.1.0 with crate(rand_isaac/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/serde1) >= 0.1.0 with crate(rand_isaac/serde1) < 0.2.0)
BuildRequires: (crate(rand_jitter/default) >= 0.1.0 with crate(rand_jitter/default) < 0.2.0)
BuildRequires: (crate(rand_jitter/std) >= 0.1.0 with crate(rand_jitter/std) < 0.2.0)
BuildRequires: (crate(rand_os/default) >= 0.1.0 with crate(rand_os/default) < 0.2.0)
BuildRequires: (crate(rand_pcg/default) >= 0.1.0 with crate(rand_pcg/default) < 0.2.0)
BuildRequires: (crate(rand_xorshift/default) >= 0.1.0 with crate(rand_xorshift/default) < 0.2.0)
@ -160,6 +162,9 @@ which use "std" feature of "%{crate}" crate.
%endif
%changelog
* Mon Jan 28 2019 Josh Stone <jistone@redhat.com> - 0.6.5-1
- Update to 0.6.5
* Thu Jan 10 2019 Josh Stone <jistone@redhat.com> - 0.6.4-1
- Update to 0.6.4

@ -1 +1 @@
SHA512 (rand-0.6.4.crate) = 2b98ba7edce4b48833ca5d8c9cda25beb9f73fd22adb997afdfb10d5c59e9240537baebc2e7de1e0094716009f7fe2b657d1f4dcb4c778e492e49483a7e3ce8b
SHA512 (rand-0.6.5.crate) = 2eb84bed29708b8ba109f4329bf6f1cac6caed9d91b2aaf185d68dd2eda73d3fb7be2897d0596fb28352e799ccf92c161ee44599d5cb426ba9c3b8c747831904

Loading…
Cancel
Save