Update to 0.6.4

epel9
Josh Stone 6 years ago
parent 28235b2d4b
commit af03082154

1
.gitignore vendored

@ -6,3 +6,4 @@
/rand-0.5.4.crate
/rand-0.5.5.crate
/rand-0.6.1.crate
/rand-0.6.4.crate

@ -1,47 +1,33 @@
--- rand-0.6.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rand-0.6.1/Cargo.toml 2018-12-03T14:32:52.470796+01:00
@@ -30,11 +30,6 @@
--- rand-0.6.4/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rand-0.6.4/Cargo.toml 2019-01-10T09:32:09.837209-08:00
@@ -28,11 +28,6 @@
all-features = true
[dependencies.log]
version = "0.4"
optional = true
-optional = true
-
-[dependencies.packed_simd]
-version = "0.3"
-features = ["into_bits"]
-optional = true
-
[dependencies.rand_chacha]
version = "0.1"
optional = true
@@ -62,31 +57,12 @@
[dependencies.rand_chacha]
@@ -69,18 +64,11 @@
alloc = ["rand_core/alloc"]
default = ["std"]
default = ["std", "rand_os"]
i128_support = []
-nightly = ["simd_support"]
serde1 = ["rand_core/serde1", "rand_isaac/serde1", "rand_xorshift/serde1"]
-simd_support = ["packed_simd"]
-std = ["rand_core/std", "alloc", "libc", "winapi", "cloudabi", "fuchsia-zircon"]
-[target."cfg(target_os = \"cloudabi\")".dependencies.cloudabi]
-version = "0.0.3"
-optional = true
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
-version = "0.3.2"
-optional = true
+std = ["rand_core/std", "alloc", "libc"]
std = ["rand_core/std", "alloc", "rand_os"]
-stdweb = ["rand_os/stdweb"]
-wasm-bindgen = ["rand_os/wasm-bindgen"]
[target."cfg(unix)".dependencies.libc]
version = "0.2"
optional = true
default-features = false
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
-optional = true
-[target.wasm32-unknown-unknown.dependencies.stdweb]
-version = "0.4"
-optional = true
-
-[target.wasm32-unknown-unknown.dependencies.wasm-bindgen]
-version = "0.2.12"
-optional = true
[badges.appveyor]
repository = "rust-random/rand"

@ -7,7 +7,7 @@
Name: rust-%{crate}
Summary: Random number generators and other randomness functionality
Version: 0.6.1
Version: 0.6.4
Release: 1%{?dist}
# Upstream license specification: MIT/Apache-2.0
@ -21,6 +21,7 @@ Patch0: rand-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(autocfg/default) >= 0.1.0 with crate(autocfg/default) < 0.2.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(rand_chacha/default) >= 0.1.0 with crate(rand_chacha/default) < 0.2.0)
@ -31,12 +32,13 @@ BuildRequires: (crate(rand_core/std) >= 0.3.0 with crate(rand_core/std) < 0.4.0
BuildRequires: (crate(rand_hc/default) >= 0.1.0 with crate(rand_hc/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/default) >= 0.1.0 with crate(rand_isaac/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/serde1) >= 0.1.0 with crate(rand_isaac/serde1) < 0.2.0)
BuildRequires: (crate(rand_os/default) >= 0.1.0 with crate(rand_os/default) < 0.2.0)
BuildRequires: (crate(rand_pcg/default) >= 0.1.0 with crate(rand_pcg/default) < 0.2.0)
BuildRequires: (crate(rand_xorshift/default) >= 0.1.0 with crate(rand_xorshift/default) < 0.2.0)
BuildRequires: (crate(rand_xorshift/serde1) >= 0.1.0 with crate(rand_xorshift/serde1) < 0.2.0)
BuildRequires: (crate(rustc_version/default) >= 0.2.0 with crate(rustc_version/default) < 0.3.0)
%if %{with check}
BuildRequires: (crate(average/default) >= 0.9.2 with crate(average/default) < 0.10.0)
BuildRequires: (crate(rand_xoshiro/default) >= 0.1.0 with crate(rand_xoshiro/default) < 0.2.0)
%endif
%global _description \
@ -94,28 +96,28 @@ which use "i128_support" feature of "%{crate}" crate.
%files -n %{name}+i128_support-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+libc-devel
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate.
which use "log" feature of "%{crate}" crate.
%files -n %{name}+libc-devel
%files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+log-devel
%package -n %{name}+rand_os-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
%description -n %{name}+rand_os-devel %{_description}
This package contains library source intended for building other packages
which use "log" feature of "%{crate}" crate.
which use "rand_os" feature of "%{crate}" crate.
%files -n %{name}+log-devel
%files -n %{name}+rand_os-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde1-devel
@ -158,6 +160,9 @@ which use "std" feature of "%{crate}" crate.
%endif
%changelog
* Thu Jan 10 2019 Josh Stone <jistone@redhat.com> - 0.6.4-1
- Update to 0.6.4
* Mon Dec 03 2018 Igor Gnatenko <ignatenkobrian@fedoraproject.org> - 0.6.1-1
- Update to 0.6.1

@ -1 +1 @@
SHA512 (rand-0.6.1.crate) = dab500d25d538d28bac5b9b60e3b262f64e9d0581c5c17f165890497f7cb459603b815e8a43451610e75d8f5390aa41aad57dcb532307c479ebb99f475f4d4a4
SHA512 (rand-0.6.4.crate) = 2b98ba7edce4b48833ca5d8c9cda25beb9f73fd22adb997afdfb10d5c59e9240537baebc2e7de1e0094716009f7fe2b657d1f4dcb4c778e492e49483a7e3ce8b

Loading…
Cancel
Save