Update to 0.6.1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent a5ffd6a802
commit 28235b2d4b
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -5,3 +5,4 @@
/rand-0.5.3.crate
/rand-0.5.4.crate
/rand-0.5.5.crate
/rand-0.6.1.crate

@ -1,17 +1,24 @@
--- rand-0.5.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rand-0.5.5/Cargo.toml 2018-10-27T02:24:57.333044+02:00
@@ -22,6 +22,7 @@
categories = ["algorithms", "no-std"]
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-lang-nursery/rand"
+exclude = ["/utils/*", "/.travis.yml", "/appveyor.yml"]
[package.metadata.docs.rs]
all-features = true
[dependencies.log]
@@ -48,22 +49,9 @@
--- rand-0.6.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rand-0.6.1/Cargo.toml 2018-12-03T14:32:52.470796+01:00
@@ -30,11 +30,6 @@
version = "0.4"
optional = true
-[dependencies.packed_simd]
-version = "0.3"
-features = ["into_bits"]
-optional = true
-
[dependencies.rand_chacha]
version = "0.1"
@@ -62,31 +57,12 @@
alloc = ["rand_core/alloc"]
default = ["std"]
i128_support = []
nightly = ["i128_support"]
serde1 = ["serde", "serde_derive", "rand_core/serde1"]
-nightly = ["simd_support"]
serde1 = ["rand_core/serde1", "rand_isaac/serde1", "rand_xorshift/serde1"]
-simd_support = ["packed_simd"]
-std = ["rand_core/std", "alloc", "libc", "winapi", "cloudabi", "fuchsia-zircon"]
-[target."cfg(target_os = \"cloudabi\")".dependencies.cloudabi]
-version = "0.0.3"
@ -22,13 +29,19 @@
+std = ["rand_core/std", "alloc", "libc"]
[target."cfg(unix)".dependencies.libc]
version = "0.2"
-optional = true
optional = true
default-features = false
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
-optional = true
-[target.wasm32-unknown-unknown.dependencies.stdweb]
-version = "0.4"
optional = true
-optional = true
-
-[target.wasm32-unknown-unknown.dependencies.wasm-bindgen]
-version = "0.2.12"
-optional = true
[badges.appveyor]
repository = "alexcrichton/rand"
repository = "rust-random/rand"

@ -6,32 +6,37 @@
%global crate rand
Name: rust-%{crate}
Version: 0.5.5
Release: 3%{?dist}
Summary: Random number generators and other randomness functionality
Version: 0.6.1
Release: 1%{?dist}
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/rand
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Exclude CI files, https://github.com/rust-random/rand/pull/635
# * Remove non-unix dependencies
Patch0: rand-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(rand_core) >= 0.2.0 with crate(rand_core) < 0.3.0)
BuildRequires: (crate(rand_core/alloc) >= 0.2.0 with crate(rand_core/alloc) < 0.3.0)
BuildRequires: (crate(rand_core/serde1) >= 0.2.0 with crate(rand_core/serde1) < 0.3.0)
BuildRequires: (crate(rand_core/std) >= 0.2.0 with crate(rand_core/std) < 0.3.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
BuildRequires: (crate(rand_chacha/default) >= 0.1.0 with crate(rand_chacha/default) < 0.2.0)
BuildRequires: (crate(rand_core) >= 0.3.0 with crate(rand_core) < 0.4.0)
BuildRequires: (crate(rand_core/alloc) >= 0.3.0 with crate(rand_core/alloc) < 0.4.0)
BuildRequires: (crate(rand_core/serde1) >= 0.3.0 with crate(rand_core/serde1) < 0.4.0)
BuildRequires: (crate(rand_core/std) >= 0.3.0 with crate(rand_core/std) < 0.4.0)
BuildRequires: (crate(rand_hc/default) >= 0.1.0 with crate(rand_hc/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/default) >= 0.1.0 with crate(rand_isaac/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/serde1) >= 0.1.0 with crate(rand_isaac/serde1) < 0.2.0)
BuildRequires: (crate(rand_pcg/default) >= 0.1.0 with crate(rand_pcg/default) < 0.2.0)
BuildRequires: (crate(rand_xorshift/default) >= 0.1.0 with crate(rand_xorshift/default) < 0.2.0)
BuildRequires: (crate(rand_xorshift/serde1) >= 0.1.0 with crate(rand_xorshift/serde1) < 0.2.0)
BuildRequires: (crate(rustc_version/default) >= 0.2.0 with crate(rustc_version/default) < 0.3.0)
%if %{with check}
BuildRequires: (crate(bincode/default) >= 1.0.0 with crate(bincode/default) < 2.0.0)
BuildRequires: (crate(average/default) >= 0.9.2 with crate(average/default) < 0.10.0)
%endif
%global _description \
@ -49,7 +54,7 @@ This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%license LICENSE-MIT LICENSE-APACHE COPYRIGHT
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
@ -113,19 +118,6 @@ which use "log" feature of "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde1-devel
Summary: %{summary}
BuildArch: noarch
@ -138,18 +130,6 @@ which use "serde1" feature of "%{crate}" crate.
%files -n %{name}+serde1-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde_derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_derive-devel %{_description}
This package contains library source intended for building other packages
which use "serde_derive" feature of "%{crate}" crate.
%files -n %{name}+serde_derive-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
@ -178,6 +158,9 @@ which use "std" feature of "%{crate}" crate.
%endif
%changelog
* Mon Dec 03 2018 Igor Gnatenko <ignatenkobrian@fedoraproject.org> - 0.6.1-1
- Update to 0.6.1
* Sat Oct 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.5-3
- Adapt to new packaging

@ -1 +1 @@
SHA512 (rand-0.5.5.crate) = e135a9c97943662bcea9c4730f19ec6e01ea73303801101592c14e97b59adbbc3457ed7a3dd57843776f5febb6fa34890aad9d1c2c596ae89416e1a281062cc8
SHA512 (rand-0.6.1.crate) = dab500d25d538d28bac5b9b60e3b262f64e9d0581c5c17f165890497f7cb459603b815e8a43451610e75d8f5390aa41aad57dcb532307c479ebb99f475f4d4a4

Loading…
Cancel
Save