You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
34 lines
942 B
34 lines
942 B
--- rand-0.6.5/Cargo.toml 1969-12-31T16:00:00-08:00
|
|
+++ rand-0.6.5/Cargo.toml 2019-01-28T14:27:08.386144-08:00
|
|
@@ -28,11 +28,6 @@
|
|
all-features = true
|
|
[dependencies.log]
|
|
version = "0.4"
|
|
-optional = true
|
|
-
|
|
-[dependencies.packed_simd]
|
|
-version = "0.3"
|
|
-features = ["into_bits"]
|
|
optional = true
|
|
|
|
[dependencies.rand_chacha]
|
|
@@ -71,18 +66,11 @@
|
|
alloc = ["rand_core/alloc"]
|
|
default = ["std"]
|
|
i128_support = []
|
|
-nightly = ["simd_support"]
|
|
serde1 = ["rand_core/serde1", "rand_isaac/serde1", "rand_xorshift/serde1"]
|
|
-simd_support = ["packed_simd"]
|
|
std = ["rand_core/std", "alloc", "rand_os", "rand_jitter/std"]
|
|
-stdweb = ["rand_os/stdweb"]
|
|
-wasm-bindgen = ["rand_os/wasm-bindgen"]
|
|
[target."cfg(unix)".dependencies.libc]
|
|
version = "0.2"
|
|
default-features = false
|
|
-[target."cfg(windows)".dependencies.winapi]
|
|
-version = "0.3"
|
|
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
|
|
[badges.appveyor]
|
|
repository = "rust-random/rand"
|
|
|