Bump goblin to 0.0.14

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent cc4c0fb16f
commit 5f08980609
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,26 @@
From dd038c59eae24707b37c6788aed6387d79f68ed6 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Thu, 18 Jan 2018 09:28:39 +0100
Subject: [PATCH] deps: update goblin to 0.0.14
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/macho.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/macho.rs b/src/macho.rs
index 1bcc4ab..e40a670 100644
--- a/src/macho.rs
+++ b/src/macho.rs
@@ -203,7 +203,7 @@ where
#[inline]
fn is_little_endian(&self) -> bool {
- self.macho.header.is_little_endian()
+ self.macho.little_endian
}
}
--
2.15.1

@ -0,0 +1,11 @@
--- object-0.7.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ object-0.7.0/Cargo.toml 2018-01-18T09:25:24.824106+01:00
@@ -19,7 +19,7 @@
license = "Apache-2.0/MIT"
repository = "https://github.com/gimli-rs/object"
[dependencies.goblin]
-version = "0.0.13"
+version = "0.0.14"
[dev-dependencies.memmap]
version = "0.6"

@ -6,18 +6,23 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.7.0 Version: 0.7.0
Release: 2%{?dist} Release: 3%{?dist}
Summary: Unified interface for the target platform's object file format Summary: Unified interface for the target platform's object file format
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/object URL: https://crates.io/crates/object
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump goblin to 0.0.14, https://github.com/gimli-rs/object/pull/46
Patch0: object-0.7.0-fix-metadata.diff
# Make it work with goblin v0.0.14
Patch1: 0001-deps-update-goblin-to-0.0.14.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
# [dependencies] # [dependencies]
BuildRequires: (crate(goblin) >= 0.0.13 with crate(goblin) < 0.0.14) BuildRequires: (crate(goblin) >= 0.0.14 with crate(goblin) < 0.0.15)
%if %{with check} %if %{with check}
# [dev-dependencies] # [dev-dependencies]
BuildRequires: (crate(memmap) >= 0.6.0 with crate(memmap) < 0.7.0) BuildRequires: (crate(memmap) >= 0.6.0 with crate(memmap) < 0.7.0)
@ -58,6 +63,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/coverage %exclude %{cargo_registry}/%{crate}-%{version}/coverage
%changelog %changelog
* Thu Jan 18 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-3
- Bump goblin to 0.0.14
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-2 * Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-2
- Rebuild for rust-packaging v5 - Rebuild for rust-packaging v5

Loading…
Cancel
Save