parent
29dc4eb49a
commit
10ab40226c
@ -0,0 +1 @@
|
||||
./nu-system-0.65.0.crate
|
@ -0,0 +1,59 @@
|
||||
--- nu-system-0.65.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ nu-system-0.65.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
@@ -29,56 +29,3 @@
|
||||
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.procfs]
|
||||
version = "0.12.0"
|
||||
|
||||
-[target."cfg(target_os = \"macos\")".dependencies.errno]
|
||||
-version = "0.2"
|
||||
-
|
||||
-[target."cfg(target_os = \"macos\")".dependencies.libc]
|
||||
-version = "0.2"
|
||||
-
|
||||
-[target."cfg(target_os = \"macos\")".dependencies.libproc]
|
||||
-version = "0.10"
|
||||
-
|
||||
-[target."cfg(target_os = \"windows\")".dependencies.chrono]
|
||||
-version = "0.4"
|
||||
-
|
||||
-[target."cfg(target_os = \"windows\")".dependencies.libc]
|
||||
-version = "0.2"
|
||||
-
|
||||
-[target."cfg(target_os = \"windows\")".dependencies.ntapi]
|
||||
-version = "0.3"
|
||||
-
|
||||
-[target."cfg(target_os = \"windows\")".dependencies.once_cell]
|
||||
-version = "1.0"
|
||||
-
|
||||
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
|
||||
-version = "0.3.9"
|
||||
-features = [
|
||||
- "tlhelp32",
|
||||
- "fileapi",
|
||||
- "handleapi",
|
||||
- "ifdef",
|
||||
- "ioapiset",
|
||||
- "minwindef",
|
||||
- "pdh",
|
||||
- "psapi",
|
||||
- "synchapi",
|
||||
- "sysinfoapi",
|
||||
- "winbase",
|
||||
- "winerror",
|
||||
- "winioctl",
|
||||
- "winnt",
|
||||
- "oleauto",
|
||||
- "wbemcli",
|
||||
- "rpcdce",
|
||||
- "combaseapi",
|
||||
- "objidl",
|
||||
- "powerbase",
|
||||
- "netioapi",
|
||||
- "lmcons",
|
||||
- "lmaccess",
|
||||
- "lmapibuf",
|
||||
- "memoryapi",
|
||||
- "shellapi",
|
||||
- "std",
|
||||
- "securitybaseapi",
|
||||
-]
|
@ -0,0 +1,79 @@
|
||||
# Generated by rust2rpm 22
|
||||
%bcond_without check
|
||||
|
||||
%global crate nu-system
|
||||
|
||||
Name: rust-nu-system
|
||||
Version: 0.65.0
|
||||
Release: %autorelease
|
||||
Summary: Nushell system querying
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/nu-system
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: nu-system-fix-metadata-auto.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Nushell system querying.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package -n %{crate}
|
||||
Summary: %{summary}
|
||||
|
||||
%description -n %{crate} %{_description}
|
||||
|
||||
%files -n %{crate}
|
||||
%license LICENSE
|
||||
%{_bindir}/ps
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue