Update to 5.1.1

epel9
Josh Stone 5 years ago
parent 794daf4110
commit 7a54ec00a9

1
.gitignore vendored

@ -8,3 +8,4 @@
/nom-4.2.3.crate
/nom-5.0.1.crate
/nom-5.1.0.crate
/nom-5.1.1.crate

@ -1,35 +0,0 @@
From 72fbb0df336c28ecc5df02adcec512d565f845a4 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Tue, 26 Nov 2019 10:55:53 +0100
Subject: [PATCH] chore: Update version_check to 0.9
Also simplify build.rs.
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
build.rs | 10 ++--------
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/build.rs b/build.rs
index 994d7f9..9743c90 100644
--- a/build.rs
+++ b/build.rs
@@ -1,13 +1,7 @@
extern crate version_check;
fn main() {
- match version_check::is_min_version("1.28.0") {
- Some((true, _actual_version)) => {
- println!("cargo:rustc-cfg=stable_i128");
- }
- Some(_) => (),
- None => {
- eprintln!("couldn't query version info from rustc");
- }
+ if version_check::is_min_version("1.28.0").unwrap_or(true) {
+ println!("cargo:rustc-cfg=stable_i128");
}
}
--
2.24.0

@ -1,6 +1,6 @@
--- nom-5.0.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ nom-5.0.1/Cargo.toml 2019-11-26T19:03:02.515466+00:00
@@ -34,16 +34,6 @@
--- nom-5.1.1/Cargo.toml 2020-02-24T14:11:07+00:00
+++ nom-5.1.1/Cargo.toml 2020-02-24T18:47:00.574520+00:00
@@ -34,21 +34,6 @@
[lib]
bench = false
@ -13,11 +13,16 @@
-[[example]]
-name = "s_expression"
-path = "examples/s_expression.rs"
-required-features = ["alloc"]
-
-[[example]]
-name = "string"
-path = "examples/string.rs"
-required-features = ["alloc"]
[[test]]
name = "arithmetic"
@@ -102,35 +92,6 @@
@@ -107,41 +92,12 @@
[[test]]
name = "test1"
@ -53,21 +58,25 @@
[dependencies.lazy_static]
version = "^1.0"
optional = true
@@ -146,16 +107,11 @@
[dependencies.lexical-core]
-version = "^0.6.0"
+version = "^0.7.0"
optional = true
[dependencies.memchr]
@@ -151,14 +107,10 @@
[dependencies.regex]
version = "^1.0"
optional = true
-[dev-dependencies.criterion]
-version = "0.2"
-
[dev-dependencies.doc-comment]
version = "0.3"
-[dev-dependencies.jemallocator]
-version = "^0.1"
[build-dependencies.version_check]
-version = "^0.1"
+version = "0.9"
version = "0.9"
[features]
alloc = []

@ -5,8 +5,8 @@
%global crate nom
Name: rust-%{crate}
Version: 5.1.0
Release: 2%{?dist}
Version: 5.1.1
Release: 1%{?dist}
Summary: Byte-oriented, zero-copy, parser combinators library
# Upstream license specification: MIT
@ -15,10 +15,8 @@ URL: https://crates.io/crates/nom
Source: %{crates_source}
# Initial patched metadata
# * the benches/examples are not included in the package
# * Update version_check to 0.9, https://github.com/Geal/nom/pull/1073
# * bump lexical-core to 0.7 (not upstream due to raised MSRV)
Patch0: nom-fix-metadata.diff
# * Finish version_check update
Patch0001: 0001-chore-Update-version_check-to-0.9.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -173,6 +171,9 @@ which use "std" feature of "%{crate}" crate.
%endif
%changelog
* Mon Feb 24 2020 Josh Stone <jistone@redhat.com> - 5.1.1-1
- Update to 5.1.1
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (nom-5.1.0.crate) = 1dde6428224f0cf8b7169337335541fdceb8aee0fa164284919f73cc39a50c098428522901833847135aadafa7a95f29921d987544086cfc9684fe7b13a8a00b
SHA512 (nom-5.1.1.crate) = 947ee383f906336912daec1db1d2b3ac74364a650f733594df172136683fd238fb7eeb93f6cdd6da3bea3e05a6257f244e9ac58a7311c80a1eaaa3156b80b07f

Loading…
Cancel
Save