You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-nom/nom-fix-metadata.diff

83 lines
1.4 KiB

--- nom-5.1.1/Cargo.toml 2020-02-24T14:11:07+00:00
+++ nom-5.1.1/Cargo.toml 2020-02-24T18:47:00.574520+00:00
@@ -34,21 +34,6 @@
[lib]
bench = false
-
-[[example]]
-name = "json"
-path = "examples/json.rs"
-required-features = ["alloc"]
-
-[[example]]
-name = "s_expression"
-path = "examples/s_expression.rs"
-required-features = ["alloc"]
-
-[[example]]
-name = "string"
-path = "examples/string.rs"
-required-features = ["alloc"]
[[test]]
name = "arithmetic"
@@ -107,41 +92,12 @@
[[test]]
name = "test1"
-[[bench]]
-name = "arithmetic"
-path = "benches/arithmetic.rs"
-harness = false
-
-[[bench]]
-name = "http"
-path = "benches/http.rs"
-harness = false
-
-[[bench]]
-name = "ini"
-path = "benches/ini.rs"
-harness = false
-
-[[bench]]
-name = "ini_complete"
-path = "benches/ini_complete.rs"
-harness = false
-
-[[bench]]
-name = "ini_str"
-path = "benches/ini_str.rs"
-harness = false
-
-[[bench]]
-name = "json"
-path = "benches/json.rs"
-harness = false
[dependencies.lazy_static]
version = "^1.0"
optional = true
[dependencies.lexical-core]
-version = "^0.6.0"
+version = "^0.7.0"
optional = true
[dependencies.memchr]
@@ -151,14 +107,10 @@
[dependencies.regex]
version = "^1.0"
optional = true
-[dev-dependencies.criterion]
-version = "0.2"
[dev-dependencies.doc-comment]
version = "0.3"
-[dev-dependencies.jemallocator]
-version = "^0.1"
[build-dependencies.version_check]
version = "0.9"