|
|
@ -1,6 +1,6 @@
|
|
|
|
--- mio-0.8.11/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
--- mio-1.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
+++ mio-0.8.11/Cargo.toml 2024-03-08T09:26:49.823188+00:00
|
|
|
|
+++ mio-1.0.1/Cargo.toml 2024-07-28T14:17:26.419522+00:00
|
|
|
|
@@ -103,26 +103,9 @@
|
|
|
|
@@ -118,36 +118,11 @@
|
|
|
|
net = []
|
|
|
|
net = []
|
|
|
|
os-ext = [
|
|
|
|
os-ext = [
|
|
|
|
"os-poll",
|
|
|
|
"os-poll",
|
|
|
@ -8,22 +8,37 @@
|
|
|
|
- "windows-sys/Win32_Security",
|
|
|
|
- "windows-sys/Win32_Security",
|
|
|
|
]
|
|
|
|
]
|
|
|
|
os-poll = []
|
|
|
|
os-poll = []
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
-[target.'cfg(target_os = "hermit")'.dependencies.libc]
|
|
|
|
|
|
|
|
-version = "0.3.9"
|
|
|
|
|
|
|
|
-package = "hermit-abi"
|
|
|
|
-
|
|
|
|
-
|
|
|
|
-[target."cfg(target_os = \"wasi\")".dependencies.libc]
|
|
|
|
-[target.'cfg(target_os = "wasi")'.dependencies.libc]
|
|
|
|
-version = "0.2.149"
|
|
|
|
-version = "0.2.149"
|
|
|
|
-
|
|
|
|
-
|
|
|
|
-[target."cfg(target_os = \"wasi\")".dependencies.wasi]
|
|
|
|
-[target.'cfg(target_os = "wasi")'.dependencies.wasi]
|
|
|
|
-version = "0.11.0"
|
|
|
|
-version = "0.11.0"
|
|
|
|
|
|
|
|
-
|
|
|
|
[target."cfg(unix)".dependencies.libc]
|
|
|
|
[target."cfg(unix)".dependencies.libc]
|
|
|
|
version = "0.2.149"
|
|
|
|
version = "0.2.149"
|
|
|
|
|
|
|
|
-
|
|
|
|
-[target."cfg(windows)".dependencies.windows-sys]
|
|
|
|
-[target."cfg(windows)".dependencies.windows-sys]
|
|
|
|
-version = "0.48"
|
|
|
|
-version = "0.52"
|
|
|
|
-features = [
|
|
|
|
-features = [
|
|
|
|
|
|
|
|
- "Wdk_Foundation",
|
|
|
|
|
|
|
|
- "Wdk_Storage_FileSystem",
|
|
|
|
|
|
|
|
- "Wdk_System_IO",
|
|
|
|
- "Win32_Foundation",
|
|
|
|
- "Win32_Foundation",
|
|
|
|
- "Win32_Networking_WinSock",
|
|
|
|
- "Win32_Networking_WinSock",
|
|
|
|
- "Win32_Storage_FileSystem",
|
|
|
|
- "Win32_Storage_FileSystem",
|
|
|
|
- "Win32_System_IO",
|
|
|
|
- "Win32_System_IO",
|
|
|
|
- "Win32_System_WindowsProgramming",
|
|
|
|
- "Win32_System_WindowsProgramming",
|
|
|
|
-]
|
|
|
|
-]
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
[lints.rust.unexpected_cfgs]
|
|
|
|
|
|
|
|
level = "warn"
|
|
|
|
|
|
|
|
@@ -156,3 +131,4 @@
|
|
|
|
|
|
|
|
"cfg(mio_unsupported_force_poll_poll)",
|
|
|
|
|
|
|
|
"cfg(mio_unsupported_force_waker_pipe)",
|
|
|
|
|
|
|
|
]
|
|
|
|
|
|
|
|
+
|
|
|
|