You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-mio/mio-fix-metadata-auto.diff

45 lines
1.0 KiB

--- mio-1.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ mio-1.0.1/Cargo.toml 2024-07-28T14:17:26.419522+00:00
@@ -118,36 +118,11 @@
net = []
os-ext = [
"os-poll",
- "windows-sys/Win32_System_Pipes",
- "windows-sys/Win32_Security",
]
os-poll = []
-[target.'cfg(target_os = "hermit")'.dependencies.libc]
-version = "0.3.9"
-package = "hermit-abi"
-
-[target.'cfg(target_os = "wasi")'.dependencies.libc]
-version = "0.2.149"
-
-[target.'cfg(target_os = "wasi")'.dependencies.wasi]
-version = "0.11.0"
-
[target."cfg(unix)".dependencies.libc]
version = "0.2.149"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.52"
-features = [
- "Wdk_Foundation",
- "Wdk_Storage_FileSystem",
- "Wdk_System_IO",
- "Win32_Foundation",
- "Win32_Networking_WinSock",
- "Win32_Storage_FileSystem",
- "Win32_System_IO",
- "Win32_System_WindowsProgramming",
-]
[lints.rust.unexpected_cfgs]
level = "warn"
@@ -156,3 +131,4 @@
"cfg(mio_unsupported_force_poll_poll)",
"cfg(mio_unsupported_force_waker_pipe)",
]
+