parent
d6a8e6b2a1
commit
67b86278c1
@ -1,95 +0,0 @@
|
|||||||
--- minimal-lexical-0.1.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
|
||||||
+++ minimal-lexical-0.1.2/Cargo.toml 2021-08-22T10:31:01.146073+00:00
|
|
||||||
@@ -25,85 +25,6 @@
|
|
||||||
categories = ["parsing", "no-std"]
|
|
||||||
license = "MIT/Apache-2.0"
|
|
||||||
repository = "https://github.com/Alexhuszagh/minimal-lexical"
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "simple-example"
|
|
||||||
-path = "examples/simple.rs"
|
|
||||||
-required-features = ["examples"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "smoke-test"
|
|
||||||
-path = "rng-tests/smoke.rs"
|
|
||||||
-required-features = ["rng"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "f32-test"
|
|
||||||
-path = "rng-tests/f32.rs"
|
|
||||||
-required-features = ["rng"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "few_ones"
|
|
||||||
-path = "data/test-parse-random/few_ones.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "huge-pow10"
|
|
||||||
-path = "data/test-parse-random/huge-pow10.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "long-fractions"
|
|
||||||
-path = "data/test-parse-random/long-fractions.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "many-digits"
|
|
||||||
-path = "data/test-parse-random/many-digits.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "rand-f64"
|
|
||||||
-path = "data/test-parse-random/rand-f64.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "short-decimals"
|
|
||||||
-path = "data/test-parse-random/short-decimals.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "subnorm"
|
|
||||||
-path = "data/test-parse-random/subnorm.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "tiny-pow10"
|
|
||||||
-path = "data/test-parse-random/tiny-pow10.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "u32-small"
|
|
||||||
-path = "data/test-parse-random/u32-small.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "u64-pow2"
|
|
||||||
-path = "data/test-parse-random/u64-pow2.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "test-parse-unittests"
|
|
||||||
-path = "data/test-parse-unittests/main.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-
|
|
||||||
-[[bin]]
|
|
||||||
-name = "test-parse-golang"
|
|
||||||
-path = "data/test-parse-golang/main.rs"
|
|
||||||
-required-features = ["comprehensive_float_test"]
|
|
||||||
-[dependencies.arrayvec]
|
|
||||||
-version = "0.4"
|
|
||||||
-features = ["array-sizes-33-128"]
|
|
||||||
-optional = true
|
|
||||||
|
|
||||||
[dependencies.rand]
|
|
||||||
version = "0.4"
|
|
||||||
@@ -137,6 +58,5 @@
|
|
||||||
comprehensive_float_test = ["rand/std", "serde/std", "serde_derive", "std", "toml"]
|
|
||||||
default = ["std"]
|
|
||||||
examples = []
|
|
||||||
-no_alloc = ["arrayvec"]
|
|
||||||
rng = ["rand_core", "rand_xorshift", "ryu"]
|
|
||||||
std = []
|
|
@ -1 +1 @@
|
|||||||
SHA512 (minimal-lexical-0.1.2.crate) = 18db0435df97f5766ca3b73ea085a599b44aa6535d76fc1a5e58550cb7aecc0f893887cfacdd377ae697ab7cceadc10d4311cdd931bea264adb1d5ed096f2e40
|
SHA512 (minimal-lexical-0.2.1.crate) = 385fab51884bdcc7b0f2728a219ab164d0dc8efe42160b918f2c09f79ecf853fb12bda006d11e649f097bae1499dcd41ddf2a8784ee7d178cf2c28059e46078c
|
||||||
|
Loading…
Reference in new issue