Update to version 0.2.1; Fixes RHBZ#2001245

epel9
Fabio Valentini 3 years ago
parent d6a8e6b2a1
commit 67b86278c1
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/*.src.rpm /*.src.rpm
/minimal-lexical-0.1.2.crate /minimal-lexical-0.1.2.crate
/minimal-lexical-0.2.1.crate

@ -1,95 +0,0 @@
--- minimal-lexical-0.1.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ minimal-lexical-0.1.2/Cargo.toml 2021-08-22T10:31:01.146073+00:00
@@ -25,85 +25,6 @@
categories = ["parsing", "no-std"]
license = "MIT/Apache-2.0"
repository = "https://github.com/Alexhuszagh/minimal-lexical"
-
-[[bin]]
-name = "simple-example"
-path = "examples/simple.rs"
-required-features = ["examples"]
-
-[[bin]]
-name = "smoke-test"
-path = "rng-tests/smoke.rs"
-required-features = ["rng"]
-
-[[bin]]
-name = "f32-test"
-path = "rng-tests/f32.rs"
-required-features = ["rng"]
-
-[[bin]]
-name = "few_ones"
-path = "data/test-parse-random/few_ones.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "huge-pow10"
-path = "data/test-parse-random/huge-pow10.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "long-fractions"
-path = "data/test-parse-random/long-fractions.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "many-digits"
-path = "data/test-parse-random/many-digits.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "rand-f64"
-path = "data/test-parse-random/rand-f64.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "short-decimals"
-path = "data/test-parse-random/short-decimals.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "subnorm"
-path = "data/test-parse-random/subnorm.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "tiny-pow10"
-path = "data/test-parse-random/tiny-pow10.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "u32-small"
-path = "data/test-parse-random/u32-small.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "u64-pow2"
-path = "data/test-parse-random/u64-pow2.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "test-parse-unittests"
-path = "data/test-parse-unittests/main.rs"
-required-features = ["comprehensive_float_test"]
-
-[[bin]]
-name = "test-parse-golang"
-path = "data/test-parse-golang/main.rs"
-required-features = ["comprehensive_float_test"]
-[dependencies.arrayvec]
-version = "0.4"
-features = ["array-sizes-33-128"]
-optional = true
[dependencies.rand]
version = "0.4"
@@ -137,6 +58,5 @@
comprehensive_float_test = ["rand/std", "serde/std", "serde_derive", "std", "toml"]
default = ["std"]
examples = []
-no_alloc = ["arrayvec"]
rng = ["rand_core", "rand_xorshift", "ryu"]
std = []

@ -5,7 +5,7 @@
%global crate minimal-lexical %global crate minimal-lexical
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.1.2 Version: 0.2.1
Release: %autorelease Release: %autorelease
Summary: Fast float parsing conversion routines Summary: Fast float parsing conversion routines
@ -13,10 +13,6 @@ Summary: Fast float parsing conversion routines
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/minimal-lexical URL: https://crates.io/crates/minimal-lexical
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * drop example binaries
# * drop optional no_alloc feature with outdated arrayvec dependency
Patch0: minimal-lexical-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -56,112 +52,52 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+comprehensive_float_test-devel %package -n %{name}+alloc-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+comprehensive_float_test-devel %{_description} %description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "comprehensive_float_test" feature of "%{crate}" crate. which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+comprehensive_float_test-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+examples-devel %package -n %{name}+compact-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+examples-devel %{_description} %description -n %{name}+compact-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "examples" feature of "%{crate}" crate. which use "compact" feature of "%{crate}" crate.
%files -n %{name}+examples-devel %files -n %{name}+compact-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand-devel %package -n %{name}+lint-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+rand-devel %{_description} %description -n %{name}+lint-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "rand" feature of "%{crate}" crate. which use "lint" feature of "%{crate}" crate.
%files -n %{name}+rand-devel %files -n %{name}+lint-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand_core-devel %package -n %{name}+nightly-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+rand_core-devel %{_description} %description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "rand_core" feature of "%{crate}" crate. which use "nightly" feature of "%{crate}" crate.
%files -n %{name}+rand_core-devel %files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand_xorshift-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand_xorshift-devel %{_description}
This package contains library source intended for building other packages
which use "rand_xorshift" feature of "%{crate}" crate.
%files -n %{name}+rand_xorshift-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rng-devel %{_description}
This package contains library source intended for building other packages
which use "rng" feature of "%{crate}" crate.
%files -n %{name}+rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+ryu-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ryu-devel %{_description}
This package contains library source intended for building other packages
which use "ryu" feature of "%{crate}" crate.
%files -n %{name}+ryu-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde_derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_derive-devel %{_description}
This package contains library source intended for building other packages
which use "serde_derive" feature of "%{crate}" crate.
%files -n %{name}+serde_derive-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
@ -176,18 +112,6 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+toml-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+toml-devel %{_description}
This package contains library source intended for building other packages
which use "toml" feature of "%{crate}" crate.
%files -n %{name}+toml-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep

@ -1 +1 @@
SHA512 (minimal-lexical-0.1.2.crate) = 18db0435df97f5766ca3b73ea085a599b44aa6535d76fc1a5e58550cb7aecc0f893887cfacdd377ae697ab7cceadc10d4311cdd931bea264adb1d5ed096f2e40 SHA512 (minimal-lexical-0.2.1.crate) = 385fab51884bdcc7b0f2728a219ab164d0dc8efe42160b918f2c09f79ecf853fb12bda006d11e649f097bae1499dcd41ddf2a8784ee7d178cf2c28059e46078c

Loading…
Cancel
Save