Initial import (#1996374)
parent
aa79c7c915
commit
d6a8e6b2a1
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/minimal-lexical-0.1.2.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-minimal-lexical
|
||||
|
||||
The rust-minimal-lexical package
|
@ -0,0 +1,95 @@
|
||||
--- minimal-lexical-0.1.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ minimal-lexical-0.1.2/Cargo.toml 2021-08-22T10:31:01.146073+00:00
|
||||
@@ -25,85 +25,6 @@
|
||||
categories = ["parsing", "no-std"]
|
||||
license = "MIT/Apache-2.0"
|
||||
repository = "https://github.com/Alexhuszagh/minimal-lexical"
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "simple-example"
|
||||
-path = "examples/simple.rs"
|
||||
-required-features = ["examples"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "smoke-test"
|
||||
-path = "rng-tests/smoke.rs"
|
||||
-required-features = ["rng"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "f32-test"
|
||||
-path = "rng-tests/f32.rs"
|
||||
-required-features = ["rng"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "few_ones"
|
||||
-path = "data/test-parse-random/few_ones.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "huge-pow10"
|
||||
-path = "data/test-parse-random/huge-pow10.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "long-fractions"
|
||||
-path = "data/test-parse-random/long-fractions.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "many-digits"
|
||||
-path = "data/test-parse-random/many-digits.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "rand-f64"
|
||||
-path = "data/test-parse-random/rand-f64.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "short-decimals"
|
||||
-path = "data/test-parse-random/short-decimals.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "subnorm"
|
||||
-path = "data/test-parse-random/subnorm.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "tiny-pow10"
|
||||
-path = "data/test-parse-random/tiny-pow10.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "u32-small"
|
||||
-path = "data/test-parse-random/u32-small.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "u64-pow2"
|
||||
-path = "data/test-parse-random/u64-pow2.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "test-parse-unittests"
|
||||
-path = "data/test-parse-unittests/main.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "test-parse-golang"
|
||||
-path = "data/test-parse-golang/main.rs"
|
||||
-required-features = ["comprehensive_float_test"]
|
||||
-[dependencies.arrayvec]
|
||||
-version = "0.4"
|
||||
-features = ["array-sizes-33-128"]
|
||||
-optional = true
|
||||
|
||||
[dependencies.rand]
|
||||
version = "0.4"
|
||||
@@ -137,6 +58,5 @@
|
||||
comprehensive_float_test = ["rand/std", "serde/std", "serde_derive", "std", "toml"]
|
||||
default = ["std"]
|
||||
examples = []
|
||||
-no_alloc = ["arrayvec"]
|
||||
rng = ["rand_core", "rand_xorshift", "ryu"]
|
||||
std = []
|
@ -0,0 +1,210 @@
|
||||
# Generated by rust2rpm 18
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate minimal-lexical
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.2
|
||||
Release: %autorelease
|
||||
Summary: Fast float parsing conversion routines
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/minimal-lexical
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop example binaries
|
||||
# * drop optional no_alloc feature with outdated arrayvec dependency
|
||||
Patch0: minimal-lexical-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Fast float parsing conversion routines.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md CHANGELOG
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+comprehensive_float_test-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+comprehensive_float_test-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "comprehensive_float_test" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+comprehensive_float_test-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+examples-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+examples-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "examples" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+examples-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "rand" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand_core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand_core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "rand_core" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand_core-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand_xorshift-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand_xorshift-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "rand_xorshift" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand_xorshift-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rng-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rng-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "rng" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rng-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+ryu-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+ryu-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "ryu" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+ryu-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "serde" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde_derive-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde_derive-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "serde_derive" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde_derive-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "std" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+toml-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+toml-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "toml" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+toml-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue