parent
d045414efe
commit
9d9cd96777
@ -1,25 +1,35 @@
|
||||
--- memsec-0.6.0/Cargo.toml 2020-07-29T17:25:03+00:00
|
||||
+++ memsec-0.6.0/Cargo.toml 2021-04-12T09:26:20.491322+00:00
|
||||
@@ -21,6 +21,7 @@
|
||||
categories = ["no-std", "memory-management"]
|
||||
--- memsec-0.6.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ memsec-0.6.2/Cargo.toml 2022-05-12T13:45:21.043716+00:00
|
||||
@@ -28,6 +28,7 @@
|
||||
]
|
||||
license = "MIT"
|
||||
repository = "https://github.com/quininer/memsec"
|
||||
+exclude = ["appveyor.yml"]
|
||||
|
||||
[dependencies.getrandom]
|
||||
version = "0.1"
|
||||
optional = true
|
||||
@@ -29,13 +30,9 @@
|
||||
alloc = ["getrandom", "use_os"]
|
||||
default = ["use_os", "alloc"]
|
||||
version = "0.2"
|
||||
@@ -45,24 +46,12 @@
|
||||
nightly = []
|
||||
-use_os = ["libc", "winapi"]
|
||||
+use_os = ["libc"]
|
||||
use_os = [
|
||||
"libc",
|
||||
- "windows-sys",
|
||||
]
|
||||
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2"
|
||||
-optional = true
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["memoryapi", "sysinfoapi"]
|
||||
optional = true
|
||||
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.36"
|
||||
-features = [
|
||||
- "Win32_System_SystemInformation",
|
||||
- "Win32_System_Memory",
|
||||
- "Win32_Foundation",
|
||||
- "Win32_System_Diagnostics_Debug",
|
||||
-]
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
[badges.appveyor]
|
||||
repository = "quininer/memsec"
|
||||
|
||||
|
@ -1 +1 @@
|
||||
SHA512 (memsec-0.6.0.crate) = 326bd28be5fe98720f0d57a96154e7746bd9fc5b4e8bd827361f6dcbf15f83321b5f0519ddad38f0bcbf4a043a7ef3cdec24ef6539915b007a0e85b01c584bad
|
||||
SHA512 (memsec-0.6.2.crate) = 07588f961d1b8cdff8accfcf03a2dcc28246c8dbd902929a6f0a4def387a39d50d4b276e523e7fd669bd22296252a379d12fb63b22f5014e8ee69811fd355112
|
||||
|
Loading…
Reference in new issue