Update to version 0.6.2; Fixes RHBZ#2078975

epel9
Fabio Valentini 3 years ago
parent d045414efe
commit 9d9cd96777
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/*.src.rpm /*.src.rpm
/memsec-0.6.0.crate /memsec-0.6.0.crate
/memsec-0.6.2.crate

@ -1,25 +1,35 @@
--- memsec-0.6.0/Cargo.toml 2020-07-29T17:25:03+00:00 --- memsec-0.6.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ memsec-0.6.0/Cargo.toml 2021-04-12T09:26:20.491322+00:00 +++ memsec-0.6.2/Cargo.toml 2022-05-12T13:45:21.043716+00:00
@@ -21,6 +21,7 @@ @@ -28,6 +28,7 @@
categories = ["no-std", "memory-management"] ]
license = "MIT" license = "MIT"
repository = "https://github.com/quininer/memsec" repository = "https://github.com/quininer/memsec"
+exclude = ["appveyor.yml"] +exclude = ["appveyor.yml"]
[dependencies.getrandom] [dependencies.getrandom]
version = "0.1" version = "0.2"
optional = true @@ -45,24 +46,12 @@
@@ -29,13 +30,9 @@
alloc = ["getrandom", "use_os"]
default = ["use_os", "alloc"]
nightly = [] nightly = []
-use_os = ["libc", "winapi"] use_os = [
+use_os = ["libc"] "libc",
- "windows-sys",
]
[target."cfg(unix)".dependencies.libc] [target."cfg(unix)".dependencies.libc]
version = "0.2" version = "0.2"
-optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["memoryapi", "sysinfoapi"]
optional = true optional = true
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.36"
-features = [
- "Win32_System_SystemInformation",
- "Win32_System_Memory",
- "Win32_Foundation",
- "Win32_System_Diagnostics_Debug",
-]
-optional = true
-default-features = false
-
[badges.appveyor] [badges.appveyor]
repository = "quininer/memsec" repository = "quininer/memsec"

@ -1,11 +1,11 @@
# Generated by rust2rpm 16 # Generated by rust2rpm 21
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate memsec %global crate memsec
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.6.0 Version: 0.6.2
Release: %autorelease Release: %autorelease
Summary: Rust implementation of libsodium/utils Summary: Rust implementation of libsodium/utils
@ -19,11 +19,8 @@ Source: %{crates_source}
Patch0: memsec-fix-metadata.diff Patch0: memsec-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Rust implementation `libsodium/utils`.} Rust implementation `libsodium/utils`.}
@ -36,13 +33,13 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc README.md %doc %{crate_instdir}/README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,11 +47,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel %package -n %{name}+alloc-devel
Summary: %{summary} Summary: %{summary}
@ -62,11 +59,11 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description} %description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "alloc" feature of "%{crate}" crate. use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel %package -n %{name}+getrandom-devel
Summary: %{summary} Summary: %{summary}
@ -74,11 +71,11 @@ BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description} %description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "getrandom" feature of "%{crate}" crate. use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel %files -n %{name}+getrandom-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libc-devel %package -n %{name}+libc-devel
Summary: %{summary} Summary: %{summary}
@ -86,11 +83,11 @@ BuildArch: noarch
%description -n %{name}+libc-devel %{_description} %description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "libc" feature of "%{crate}" crate. use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel %files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel %package -n %{name}+nightly-devel
Summary: %{summary} Summary: %{summary}
@ -98,11 +95,11 @@ BuildArch: noarch
%description -n %{name}+nightly-devel %{_description} %description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "nightly" feature of "%{crate}" crate. use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel %files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+use_os-devel %package -n %{name}+use_os-devel
Summary: %{summary} Summary: %{summary}
@ -110,11 +107,11 @@ BuildArch: noarch
%description -n %{name}+use_os-devel %{_description} %description -n %{name}+use_os-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "use_os" feature of "%{crate}" crate. use the "use_os" feature of the "%{crate}" crate.
%files -n %{name}+use_os-devel %files -n %{name}+use_os-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (memsec-0.6.0.crate) = 326bd28be5fe98720f0d57a96154e7746bd9fc5b4e8bd827361f6dcbf15f83321b5f0519ddad38f0bcbf4a043a7ef3cdec24ef6539915b007a0e85b01c584bad SHA512 (memsec-0.6.2.crate) = 07588f961d1b8cdff8accfcf03a2dcc28246c8dbd902929a6f0a4def387a39d50d4b276e523e7fd669bd22296252a379d12fb63b22f5014e8ee69811fd355112

Loading…
Cancel
Save