Do not pull optional dependencies

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent dd454ec3b3
commit f6c5429731
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,18 +1,14 @@
--- linked-hash-map-0.5.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ linked-hash-map-0.5.1/Cargo.toml 2018-10-27T12:43:20.175645+02:00
@@ -21,10 +21,7 @@
+++ linked-hash-map-0.5.1/Cargo.toml 2019-03-10T20:23:48.338920+01:00
@@ -21,6 +21,7 @@
keywords = ["data-structures"]
license = "MIT/Apache-2.0"
repository = "https://github.com/contain-rs/linked-hash-map"
-[dependencies.clippy]
-version = "0.*"
-optional = true
-
+exclude = ["/.travis.yml", "/deploy-docs.sh"]
[dependencies.heapsize]
version = "0.4"
[dependencies.clippy]
version = "0.*"
optional = true
@@ -33,11 +30,10 @@
@@ -33,11 +34,10 @@
version = "1.0"
optional = true

@ -7,15 +7,14 @@
Name: rust-%{crate}
Version: 0.5.1
Release: 6%{?dist}
Release: 7%{?dist}
Summary: HashMap wrapper that holds key-value pairs in insertion order
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/linked-hash-map
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
Source: %{crates_source}
# Initial patched metadata
# * clippy is nightly
# * move serde_test to dev-deps
# * Exclude CI files, https://github.com/contain-rs/linked-hash-map/pull/94
Patch0: linked-hash-map-fix-metadata.diff
@ -23,8 +22,6 @@ Patch0: linked-hash-map-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(heapsize/default) >= 0.4.0 with crate(heapsize/default) < 0.5.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(serde_test/default) >= 1.0.0 with crate(serde_test/default) < 2.0.0)
%endif
@ -109,7 +106,7 @@ which use "serde_impl" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -124,6 +121,9 @@ which use "serde_impl" feature of "%{crate}" crate.
%endif
%changelog
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-7
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

Loading…
Cancel
Save