move serde_test to dev-deps

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 6dd3f938eb
commit 19d9cc9d12
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,13 +0,0 @@
--- linked-hash-map-0.5.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ linked-hash-map-0.5.1/Cargo.toml 2018-01-30T09:51:27.016742+01:00
@@ -21,10 +21,6 @@
keywords = ["data-structures"]
license = "MIT/Apache-2.0"
repository = "https://github.com/contain-rs/linked-hash-map"
-[dependencies.clippy]
-version = "0.*"
-optional = true
-
[dependencies.heapsize]
version = "0.4"
optional = true

@ -0,0 +1,27 @@
--- linked-hash-map-0.5.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ linked-hash-map-0.5.1/Cargo.toml 2018-10-07T16:24:16.076686+02:00
@@ -21,10 +21,6 @@
keywords = ["data-structures"]
license = "MIT/Apache-2.0"
repository = "https://github.com/contain-rs/linked-hash-map"
-[dependencies.clippy]
-version = "0.*"
-optional = true
-
[dependencies.heapsize]
version = "0.4"
optional = true
@@ -33,11 +29,10 @@
version = "1.0"
optional = true
-[dependencies.serde_test]
+[dev-dependencies.serde_test]
version = "1.0"
-optional = true
[features]
heapsize_impl = ["heapsize"]
nightly = []
-serde_impl = ["serde", "serde_test"]
+serde_impl = ["serde"]

@ -10,12 +10,14 @@ Version: 0.5.1
Release: 4%{?dist} Release: 4%{?dist}
Summary: HashMap wrapper that holds key-value pairs in insertion order Summary: HashMap wrapper that holds key-value pairs in insertion order
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/linked-hash-map URL: https://crates.io/crates/linked-hash-map
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * clippy is nightly # * clippy is nightly
Patch0: linked-hash-map-0.5.1-fix-metadata.diff # * move serde_test to dev-deps
Patch0: linked-hash-map-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -23,7 +25,10 @@ BuildRequires: rust-packaging
# [dependencies] # [dependencies]
BuildRequires: (crate(heapsize) >= 0.4.0 with crate(heapsize) < 0.5.0) BuildRequires: (crate(heapsize) >= 0.4.0 with crate(heapsize) < 0.5.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0) BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(serde_test) >= 1.0.0 with crate(serde_test) < 2.0.0) BuildRequires: (crate(serde_test) >= 1.0.0 with crate(serde_test) < 2.0.0)
%endif
%description %description
%{summary}. %{summary}.

Loading…
Cancel
Save