Update to version 0.5.3

epel9
Fabio Valentini 3 years ago
parent 09ece78345
commit 976b19f6bc
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/io-lifetimes-0.3.1.crate
/io-lifetimes-0.4.3.crate
/io-lifetimes-0.4.4.crate
/io-lifetimes-0.5.3.crate

@ -1,11 +1,19 @@
--- io-lifetimes-0.4.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-0.4.4/Cargo.toml 2022-02-03T13:56:41.549623+00:00
@@ -53,8 +53,5 @@
--- io-lifetimes-0.5.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-0.5.3/Cargo.toml 2022-04-12T09:48:03.245108+00:00
@@ -44,7 +44,7 @@
optional = true
[features]
-close = ["libc", "winapi"]
+close = ["libc"]
default = ["close"]
[target."cfg(not(target_os = \"wasi\"))".dependencies.os_pipe]
version = "1.0.0"
@@ -52,7 +52,3 @@
[target."cfg(not(windows))".dependencies.libc]
version = "0.2.96"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["handleapi", "std", "winsock2"]
[badges.maintenance]
status = "actively-developed"
-optional = true

@ -1,11 +1,11 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate io-lifetimes
Name: rust-%{crate}
Version: 0.4.4
Version: 0.5.3
Release: %autorelease
Summary: Low-level I/O ownership and borrowing library
@ -19,7 +19,7 @@ Patch0: io-lifetimes-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Low-level I/O ownership and borrowing library.}
@ -36,9 +36,12 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license COPYRIGHT LICENSE-APACHE LICENSE-Apache-2.0_WITH_LLVM-exception LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-Apache-2.0_WITH_LLVM-exception
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,7 +53,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-std-devel
Summary: %{summary}
@ -62,7 +65,7 @@ This package contains library source intended for building other packages which
use the "async-std" feature of the "%{crate}" crate.
%files -n %{name}+async-std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+close-devel
Summary: %{summary}
@ -74,7 +77,7 @@ This package contains library source intended for building other packages which
use the "close" feature of the "%{crate}" crate.
%files -n %{name}+close-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fs-err-devel
Summary: %{summary}
@ -86,7 +89,7 @@ This package contains library source intended for building other packages which
use the "fs-err" feature of the "%{crate}" crate.
%files -n %{name}+fs-err-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
@ -98,7 +101,7 @@ This package contains library source intended for building other packages which
use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mio-devel
Summary: %{summary}
@ -110,7 +113,7 @@ This package contains library source intended for building other packages which
use the "mio" feature of the "%{crate}" crate.
%files -n %{name}+mio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+os_pipe-devel
Summary: %{summary}
@ -122,7 +125,7 @@ This package contains library source intended for building other packages which
use the "os_pipe" feature of the "%{crate}" crate.
%files -n %{name}+os_pipe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+socket2-devel
Summary: %{summary}
@ -134,7 +137,7 @@ This package contains library source intended for building other packages which
use the "socket2" feature of the "%{crate}" crate.
%files -n %{name}+socket2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
@ -146,7 +149,7 @@ This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (io-lifetimes-0.4.4.crate) = 0ac4696791310c51a7f2e8df4fb98e6293c089fae8960912e4d3cd6584467db0997d7e128680e5544367dd6b20b1e9091c13df95abf63136c2412655b61a010a
SHA512 (io-lifetimes-0.5.3.crate) = 8fdb7b785aa9ad9ad256f3d5dd9e258ea6d6f3fa4c0c47326624356467ae137f7bcc64582ba94ab008fe3e0ab4279b4de3c741fe0b1b161d8fe635462f6cd265

Loading…
Cancel
Save