You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-io-lifetimes/io-lifetimes-fix-metadata.diff

20 lines
555 B

--- io-lifetimes-0.5.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-0.5.3/Cargo.toml 2022-04-12T09:48:03.245108+00:00
@@ -44,7 +44,7 @@
optional = true
[features]
-close = ["libc", "winapi"]
+close = ["libc"]
default = ["close"]
[target."cfg(not(target_os = \"wasi\"))".dependencies.os_pipe]
version = "1.0.0"
@@ -52,7 +52,3 @@
[target."cfg(not(windows))".dependencies.libc]
version = "0.2.96"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["handleapi", "std", "winsock2"]
-optional = true