Drop unused support for dns-over-https and dns-over-quic

epel10
Fabio Valentini 5 months ago
parent 68e7afe08c
commit ad5ec1c4a7
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,19 +1,5 @@
--- hickory-proto-0.24.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- hickory-proto-0.24.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hickory-proto-0.24.1/Cargo.toml 2024-04-23T13:36:51.405824+00:00 +++ hickory-proto-0.24.1/Cargo.toml 2024-09-22T01:08:09.562726+00:00
@@ -89,11 +89,11 @@
optional = true
[dependencies.h3]
-version = "0.0.2"
+version = "0.0.3"
optional = true
[dependencies.h3-quinn]
-version = "0.0.3"
+version = "0.0.4"
optional = true
[dependencies.http]
@@ -139,7 +139,7 @@ @@ -139,7 +139,7 @@
version = "0.8" version = "0.8"

@ -12,10 +12,7 @@ Summary: Hickory DNS is a safe and secure DNS library
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/hickory-proto URL: https://crates.io/crates/hickory-proto
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump ring dependency from 0.16 to 0.17 # * bump ring dependency from 0.16 to 0.17
# * bump h3 dependency from 0.0.2 to 0.0.3
# * bump h3-quinn dependency from 0.0.3 to 0.0.4
# * remove unused tracing-subscriber dev-dependency # * remove unused tracing-subscriber dev-dependency
# * add missing "tokio/io-util" dependency for the "tokio-runtime" feature # * add missing "tokio/io-util" dependency for the "tokio-runtime" feature
Patch: hickory-proto-fix-metadata.diff Patch: hickory-proto-fix-metadata.diff
@ -82,42 +79,6 @@ use the "bytes" feature of the "%{crate}" crate.
%files -n %{name}+bytes-devel %files -n %{name}+bytes-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-h3-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-h3-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-h3" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-h3-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-https-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-https-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-https" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-https-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-https-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-https-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-https-rustls" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-https-rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-native-tls-devel %package -n %{name}+dns-over-native-tls-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -142,18 +103,6 @@ use the "dns-over-openssl" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-openssl-devel %files -n %{name}+dns-over-openssl-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-quic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-quic-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-quic" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-quic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-rustls-devel %package -n %{name}+dns-over-rustls-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -226,30 +175,6 @@ use the "h2" feature of the "%{crate}" crate.
%files -n %{name}+h2-devel %files -n %{name}+h2-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+h3-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+h3-devel %{_description}
This package contains library source intended for building other packages which
use the "h3" feature of the "%{crate}" crate.
%files -n %{name}+h3-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+h3-quinn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+h3-quinn-devel %{_description}
This package contains library source intended for building other packages which
use the "h3-quinn" feature of the "%{crate}" crate.
%files -n %{name}+h3-quinn-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+http-devel %package -n %{name}+http-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -310,18 +235,6 @@ use the "openssl" feature of the "%{crate}" crate.
%files -n %{name}+openssl-devel %files -n %{name}+openssl-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quinn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quinn-devel %{_description}
This package contains library source intended for building other packages which
use the "quinn" feature of the "%{crate}" crate.
%files -n %{name}+quinn-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ring-devel %package -n %{name}+ring-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -1,7 +1,16 @@
[features] [features]
hide = [ hide = [
# WASM-specific
"js-sys", "js-sys",
"wasm-bindgen-crate", "wasm-bindgen-crate",
"wasm-bindgen", "wasm-bindgen",
# outdated dependencies
"h3",
"h3-quinn",
"quinn",
"dns-over-h3",
"dns-over-https",
"dns-over-https-rustls",
"dns-over-quic",
] ]

Loading…
Cancel
Save