Update to version 0.14.1; Fixes RHBZ#2241296

epel10
Fabio Valentini 1 year ago
parent affdd324b2
commit 4435ffe6bf
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -17,3 +17,4 @@
/hashbrown-0.12.3.crate /hashbrown-0.12.3.crate
/hashbrown-0.13.2.crate /hashbrown-0.13.2.crate
/hashbrown-0.14.0.crate /hashbrown-0.14.0.crate
/hashbrown-0.14.1.crate

@ -1,45 +0,0 @@
--- hashbrown-0.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hashbrown-0.14.0/Cargo.toml 2023-07-05T17:51:26.874507+00:00
@@ -47,25 +47,11 @@
optional = true
default-features = false
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
[dependencies.allocator-api2]
version = "0.2.9"
features = ["alloc"]
optional = true
default-features = false
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
[dependencies.rayon]
version = "1.0"
@@ -116,16 +102,4 @@
"allocator-api2",
]
inline-more = []
-nightly = [
- "allocator-api2?/nightly",
- "bumpalo/allocator_api",
-]
raw = []
-rustc-dep-of-std = [
- "nightly",
- "core",
- "compiler_builtins",
- "alloc",
- "rustc-internal-api",
-]
-rustc-internal-api = []

@ -1,22 +1,19 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate hashbrown %global crate hashbrown
Name: rust-hashbrown Name: rust-hashbrown
Version: 0.14.0 Version: 0.14.1
Release: %autorelease Release: %autorelease
Summary: Rust port of Google's SwissTable hash map Summary: Rust port of Google's SwissTable hash map
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/hashbrown URL: https://crates.io/crates/hashbrown
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop dependencies on compiler internals
Patch: hashbrown-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
A Rust port of Google's SwissTable hash map.} A Rust port of Google's SwissTable hash map.}
@ -75,6 +72,18 @@ use the "allocator-api2" feature of the "%{crate}" crate.
%files -n %{name}+allocator-api2-devel %files -n %{name}+allocator-api2-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+equivalent-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+equivalent-devel %{_description}
This package contains library source intended for building other packages which
use the "equivalent" feature of the "%{crate}" crate.
%files -n %{name}+equivalent-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+inline-more-devel %package -n %{name}+inline-more-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -136,7 +145,7 @@ use the "serde" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -0,0 +1,9 @@
[features]
hide = [
"alloc",
"compiler_builtins",
"core",
"nightly",
"rustc-dep-of-std",
"rustc-internal-api",
]

@ -1 +1 @@
SHA512 (hashbrown-0.14.0.crate) = f0fbdf81517f59a0b67f792a4097f1131d346b2b4cbda93590749cef7f9f1c9029e0e182f58c23b74d3028f7502c30b9593c1eb4da37f95388d74b14582b8959 SHA512 (hashbrown-0.14.1.crate) = 170bc233c9d23ac7e6d1ec5bc965d19d9018d434abeec19bc9f02c48570eba9db4e26035decd9f874306169d2640cad7be17bbbb78a81c145bb01bda3d51ee9c

Loading…
Cancel
Save